Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

SSO and Twitter

Hello, I have successfully connected Facebook to SSO but am having trouble with Twitter. The documentation has a slightly out of date UI throughout so I just want to confirm the terminology and settings.
Twitter has 'Application Settings' which list API key & secret, but also Access Token with corresponding key & secret. I am assuming that API is the new term for 'Consumer' in the old documentation? And I have checked the box that says "Allow this application to be used to 'Sign in with Twitter'". I've tried both but still get the error "Failed to validate oauth signature and token".
I also would like to confirm that http://my.forum.com/entry/twauthorize is still the correct Callback URL?

Thanks heaps.

Comments

  • I clicked 'Test OAuth' button in twitter's Application Management section and a page came up listing some more details... but I thought I should also check the 'Request Settings' it describes...

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff
    edited June 2014

    Are you using version 2.1 of the vanilla forums? I also recently finished a video for the Twitter connect and the idea is essentially the same for the hosted version as the open source. See below for the video.

    Hope it helps.

    Sharing is caring

    hgtonightUnderDog
  • Thanks Adrian. Yes I have 2.1 but I did notice that I don't have three checkboxes in the Twitter settings section. "Enable Social Sign In" isn't an option - I have the other two...
    Nevertheless, I continued with all the settings and still get the problem
    Do I need SSL? Why didn't facebook need it?

    UnderDog
  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff
    edited July 2014

    Hi @danielmee‌

    Please see here for the fix: http://vanillaforums.org/discussion/comment/205974/#Comment_205974

    I will make sure it gets added to the 2.1 as a bug fix for class.twitter.plugin.php

    Sharing is caring

    UnderDogvrijvlinderdanielmee
  • Thanks @Adrian - Looks like everything is working now! Cheers.

    hgtonight
Sign In or Register to comment.