HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Nothing happens even if I click on a category

I am a bit confused the way categories work. I have known it to work a board which will list the topics inside it when someone clicks on it. But on my forum www.techiewiz.in it is not working. I tried 3 different themes and it is simply displays a list of categories. Can anyone please shed some light on how to click on a category name and get all of the topics inside it listed ?

Best Answers

Answers

  • R_JR_J Ex-Fanboy Munich Admin

    Not sure if I understand your problem... If you want to see all discussions of one category, you simply have to click on the category name either in the category module or in www.example.com/categories. The link should point to www.example.com/categories/thenameofoneofyourcategories

    hgtonight
  • @R_J said:
    Not sure if I understand your problem... If you want to see all discussions of one category, you simply have to click on the category name either in the category module or in www.example.com/categories. The link should point to www.example.com/categories/thenameofoneofyourcategories

    Please do the same at www.techiewiz.in, you will understand. When I click on category name, nothing happens.

  • Actually what happened is I saved the categories as " Categories ", instead of " Default ".

  • peregrineperegrine MVP
    edited September 2014

    @meetdilip said:
    Actually what happened is I saved the categories as " Categories ", instead of " Default ".

    glad it was solved. .... but .....
    not sure what you mean, got screenshot.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    meetdilip
  • @peregrine said:

    While I create a categories there is a drop down menu with 3 options. 1. Default 2. Categories 3. ...

    I thought I should choose category as option and did it for all categories. Now I changed the drop down menu option to " Default ".

    peregrine
  • peregrineperegrine MVP
    edited September 2014

    peregrine said:

    @meetdilip said: Actually what happened is I saved the categories as " Categories ", instead of " Default ".

    peregrine said: glad it was solved. .... but ..... not sure what you mean, got screenshot.

    meetdilip said: While I create a categories there is a drop down menu with 3 options. 1. Default 2. Categories 3. ... I thought I should choose category as option and did it for all categories. Now I changed the drop down menu option to " Default ".

    thx.

    oh, ok you selected like this and that was what caused your issue. when what you wanted should have been "default" in dropdown. I never paid much attention to others and not sure what they do, other than what you experienced.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • R_JR_J Ex-Fanboy Munich Admin
    edited September 2014

    @meetdilip said:
    Please do the same at www.techiewiz.in, you will understand. When I click on category name, nothing happens.

    Nope, all like expected. Try it a) logged out and b) in another browser.

  • peregrineperegrine MVP
    edited September 2014

    r_j said: Nope, all like expected. Try it a) logged out and b) in another browser.

    it works now r_j :) problem solved.

    if you want to recreate the same issue on your forum r_j choose categories in the "Display as" dropdown instead of default.

    might be the beer playing tricks on you? :)

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited September 2014

    seems to be a new option introduced into 2.1 vs. 2.0.18.x

    not exactly sure under what circumstances someone would want to use something other than default though, and that may be the reason other people have had mysterious problems with categories (st to the worng DisplayAs field).

    code dealing with DisplayAs dropdown box relating to Category (aside from the settings itself).

    in english - This category is an overview style category and displays as a category list. ---- if Category chosen as DisplayAs (so not really clickable to see discussions it seems).

    not exactly sure what impact display as discussion really does though (although it gets changed to Category depending on NavDepth.

    from categories controller

     if ($Category->DisplayAs == 'Categories') {
                // This category is an overview style category and displays as a category list.
                switch($Layout) {
                   case 'mixed':
                      $this->View = 'discussions';
                      $this->Discussions();
                      break;
                   case 'table':
                      $this->Table();
                      break;
                   default:
                      $this->View = 'all';
                      $this->All();
                      break;
                }
                return;
             }
    

    from categorymodel.....

    if ($Category['DisplayAs'] == 'Default') {
                if ($Category['Depth'] <= C('Vanilla.Categories.NavDepth', 0))
                   $Category['DisplayAs'] = 'Categories';
                else
                   $Category['DisplayAs'] = 'Discussions';
             }
    
    
    
    
         if ($Category['DisplayAs'] == 'Categories') {
             // This is an overview category so grab it's recent data from it's children.
             foreach ($Category['ChildIDs'] as $CategoryID) {
                if (!isset($Categories[$CategoryID]))
                   continue;
    
                $ChildCategory =& $Categories[$CategoryID];
                if ($ChildCategory['DisplayAs'] == 'Categories') {
                   self::JoinRecentChildPosts($ChildCategory, $Categories);
                }
                $Timestamp = Gdn_Format::ToTimestamp($ChildCategory['LastDateInserted']);
    
                if ($LastTimestamp === FALSE || $LastTimestamp < $Timestamp) {
                   $LastTimestamp = $Timestamp;
                   $LastCategoryID = $CategoryID;
                }
             }
    
             if ($LastCategoryID) {
                $LastCategory = $Categories[$LastCategoryID];
    
                $Category['LastCommentID'] = $LastCategory['LastCommentID'];
                $Category['LastDiscussionID'] = $LastCategory['LastDiscussionID'];
                $Category['LastDateInserted'] = $LastCategory['LastDateInserted'];
                $Category['LastTitle'] = $LastCategory['LastTitle'];
                $Category['LastUserID'] = $LastCategory['LastUserID'];
                $Category['LastDiscussionUserID'] = $LastCategory['LastDiscussionUserID'];
                $Category['LastUrl'] = $LastCategory['LastUrl'];
                $Category['LastCategoryID'] = $LastCategory['CategoryID'];
             }
          }
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited September 2014

    @linc - solutionsayer badge for @meetdilip

    reporting about arcane feature and solution to their own problem. Arcane enhancement to me.

    Also, maybe a note on the form itself to give some explanatory features of implications of using

    DisplayAs Discussion vs Category vs. Default might be handy.

    http://vanillaforums.org/discussion/comment/214697/#Comment_214697

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Also if you pick "DisplayAs" Category - it will stop rss feeds on that category. even though the orange rss feeds button still appears (ehich it probably shouldn't).

    possible but probably cosmetic design bug.

    https://github.com/vanilla/vanilla/issues/2064

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.