Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

How to disable bootstap in vanilla?

In any theme I have next error in console.

Uncaught Error: Bootstrap's JavaScript requires jQuery

Where vanilla include bootsrap? I want disable him.

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    I guess you've used Bootstrap as the base for your custom theme. Or maybe you try to use a Bootstrap component? Default Vanilla is not using Bootstrap.


    phalc0nline
  • hm... Maybe some plugin initialize bootstrap. Bcs I see this error in any active theme...(bitterswet etc.) I try global search on project, but can't find anything about that

  • I found problem. Its plugin "Pockets". :(

    R_Jhgtonight
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Great you've found the source of the error, but it's not the plugin ;) I guess you have inserted content that needs Bootstrap. Look at what you've used Pockets for. You might find alternatives that don't require Bootstrap


  • No. I just enable him, don't use him. When I disable this plugin, in console all good.

  • edited March 2015

    Sorry, it's my mistake. Thank you! I use database where pockets had record with data. I am ashamed for this topic :(

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Don't be. You've found the error by yourself and that's good.


    hgtonightphalc0nline
Sign In or Register to comment.