HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Private community plugin - button not responding

This discussion is related to the Private Community addon.

Hi there, I have used this plugin before on another website and it works perfectly. However, in my new forum - the plugin has been activated but when I click the button to change the forum to private - it just won't respond.

Any ideas???

Comments

  • @ala_vanilla said:
    Any ideas???

    The idea is to look in your FireFox FireBug plugin. Maybe an ajax (jquery) request wasn't executed properly. You'll see in your FireBug what's wrong.

  • is config writeable?

    grep is your friend.

  • I really appreciate all your help but this is too technical for me. I have set up a forum on another of our websites and the private community works perfectly. On this website it's a problem.

  • edited December 2013

    [Split Dammit] I'm having this problem, too. It doesn't appear to be a browser issue, since it happens across browsers. If the problem is with permissions, please instruct on the best way to correct the issue!

  • peregrineperegrine MVP
    edited December 2013

    @nathanairplane said:
    [Split Dammit] I'm having this problem, too. It doesn't appear to be a browser issue, since it happens across browsers. If the problem is with permissions, please instruct on the best way to correct the issue!

    • I suspect you are not using the same vanilla version the op is using, so you've essentially provided no additional info for anyone to help.

    • I don't know why people would use this plugin anyway. It was last updated in 2010.

    • you can do the same thing by modifying your categories to custom permissions.
    • Allow viewing and posting permissions for those categories you want to be private to members, admins and moderators.

    edit each category and select " This category has custom permissions" assign the role permissions there

    /vanilla/settings/managecategories

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDoghgtonight
  • Thanks. I'm using Vanilla 2.0.18.4 and the current version of the plugin.

    I've done all the things you suggest. But one thing I noticed is that somebody got a ping in their WordPress account based on a link to their WordPress site that was posted in our forum, which blocked from search engines and which you have to log in to view.

    Do you have any other ideas for how to make the forum more private?

  • peregrineperegrine MVP
    edited December 2013

    I don't understand what you want. No one can read any discussion in your forum except for roles you allow, if you do what i suggested w/o the plugin.

    google cant cache the discussions if they are private as far as I know. you can block search engines - see google pages. probably some robots.txt and .htaccess. I'm no expert here.

    But one thing I noticed is that somebody got a ping in their WordPress account based on a link to their WordPress site that was posted in our forum, which blocked from search engines and which you have to log in to view.

    not sure what you mean?

    you should seriously consider upgrading 2.0.18.9 - if you are at all concerned about security. That would be my main concern if I were running a live forum.

    read these - and start a new discussion. post some scrrenshots of what you are talking about in a new discussion (if it doesn't concern this plugin). Post a new discussion - if it does concern this plugin.

    take a gander at these first:

    http://vanillaforums.org/discussion/23130/forum-post-ettikett-etiquette

    http://vanillaforums.org/discussion/17954/food-for-thought-forum-etiquette

    http://vanillaforums.org/discussion/25115/how-to-how-can-a-new-user-better-help-the-community-when-asking-a-question

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • @peregrine said:
    I don't know why people would use this plugin anyway. It was last updated in 2010.

    Seems that the permission structure for user & roles has been changed since then. The plugin checks for existing permission 'Garden.Users.Manage' which doesn't exists in my installation (instead there are distinctive permissions to add, edit, remove users). Therefor no setting is saved to the config.

    hgtonight
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Change the permissions to Garden.Settings.Manage

    DavidShinezigojacko
Sign In or Register to comment.