Please upgrade here. These earlier versions are no longer being updated and have security issues.

Pages not refreshing after login

Hi,

After my users make login, they can't see as logged users on pages which they've already accessed before.

It only appears after a refresh on the page.

Does anyone is experiencing something similar?

Comments

  • @hguarnieri said:
    Hi,

    After my users make login, they can't see as logged users on pages which they've already accessed before.

    It only appears after a refresh on the page.

    Does anyone is experiencing something similar?

    I am having the same problem too. Solution please.

  • @Prosper said:

    @hguarnieri said:
    Hi,

    After my users make login, they can't see as logged users on pages which they've already accessed before.

    It only appears after a refresh on the page.

    Does anyone is experiencing something similar?

    I am having the same problem too. Solution please.

    can you translate this into something more understandable, and provide a screenshot, and under what conditions, client browser, client os, mobile , all users, and on what pages. and what caching if any you are using.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • edited October 2016

    PHP 5.4
    MySQLServer version: 5.5.51

    Situation:

    Tested on:
    Chrome 53.0.2785.143 (64-bit)
    Safari Version 9.1 (11601.5.17.1)
    Mac OS X El Capitan 10.11.4

    Situation:

    • User not logged in
    • Go into the main page (www.experting.com.br/forum)
    • Enter some forum discussion (still not logged in)
    • Go back to the main page
    • Log in
    • Click on the same discussion
    • User is not logged. Only if I refresh the page.

    No plugins active
    Default theme
    No cache

    2.png 170.2K
    1.png 180K
    3.png 225.5K
    4.png 168.3K
  • there are a number of issues with older safari regarding stale browser cache, not sure if any of this will help you.

    https://www.google.com/search?q=+cache+safari+problem+etag

    https://www.google.com/search?q=+cache+safari+problem

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • bump - I'm having the same issue

  • kopnakopna Coimbra Portugal ☯

    Boas,
    Tenta fazer sequente - adicione as seguintes linhas no conf.php
    // Cache
    $Configuration['Cache']['Enabled'] = true;
    $Configuration['Cache']['Method'] = 'memcached';

    limpa ficheiros .ini na pasta /cache

    lipa cache (webbrowser) do seu site

    Abraço

  • @kopna said:
    Boas,
    Tenta fazer sequente - adicione as seguintes linhas no conf.php
    // Cache
    $Configuration['Cache']['Enabled'] = true;
    $Configuration['Cache']['Method'] = 'memcached';

    limpa ficheiros .ini na pasta /cache

    lipa cache (webbrowser) do seu site

    Abraço

    Please can someone translate this in English?

  • kopnakopna Coimbra Portugal ☯

    @Prosper said:

    Please can someone translate this in English?

    Add to your file config.php next
    // Cache
    $Configuration['Cache']['Enabled'] = true;
    $Configuration['Cache']['Method'] = 'memcached';

    Add also the line
    $Configuration['Garden']['RewriteUrls'] = true;

    To clean .ini files in the /cache folder

    Clear your site's web browser cache

  • @kopna said:

    @Prosper said:

    Please can someone translate this in English?

    Add to your file config.php next
    // Cache
    $Configuration['Cache']['Enabled'] = true;
    $Configuration['Cache']['Method'] = 'memcached';

    Add also the line
    $Configuration['Garden']['RewriteUrls'] = true;

    To clean .ini files in the /cache folder

    Clear your site's web browser cache

    My config.php already had all those settings on and I had cleared the cache multiple times, to no avail.

    If there was a way for the browser to refresh its cache for your website when he clicks on "login" I'm pretty sure that would solve all issues (because if you manually press Ctrl+F5 after logging in, it works perfectly), but this doesn't seem possible from my Googling :/

    Thanks for the answer though @kopna - any more help would be hugely appreciated

Sign In or Register to comment.