HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Topic category

kopnakopna Coimbra Portugal ☯

Click on a category

get the following

Click on the link in this category

get a full page?

What happened and why it is impossible to switch on the category page :o

Comments

  • RiverRiver MVP
    edited December 2016

    @kopna said: what hapened

    How would you solve the problem!

    here is a simple way to determine and potentially solve problem.

    switch to the default theme. disable all plugins. remove any changes you may have made. verify your rewrite rules are correct. turn debugging on. look in debugging logs for problems. then you can possibly determine if it is core problem, theme, or plugin, rewrite rules. also determine if it is a problem for all categories or just certain ones. perhaps there is a character in the category name that causes problems if some categories work and others don't.

    The reason I give you these simple troubleshooting steps is because of some of your questions, problems, and solutions.

    Here is an simple example.

    You may provide a question similar to: I live a 100 yards from a store, it is raining, I want to eat breakfast of eggs, but I don't have any eggs, it is raining, how do I get breakfast without getting clothes wet.

    volunteers provide you solutions e.g. Put on rain coat, or use umbrella, go to store, walk to store, buy eggs at store, walk home and cook eggs.

    You then come back with your answer, and say I have no stove to cook eggs, so I put on my bathing suit, swam across a river for 100 yards to reach the store, the store was a clothing store and had no eggs, so I hitchhiked to the airport, and bought my dinner of eggs there.

    sometimes you can solve the problem yourself.

    http://docs.vanillaforums.com/developer/troubleshooting/

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    Fraktar
  • kopnakopna Coimbra Portugal ☯

    @River написал:

    @kopna said: what hapened

    How would you solve the problem!

    here is a simple way to determine and potentially solve problem.

    switch to the default theme. disable all plugins. remove any changes you may have made. verify your rewrite rules are correct. turn debugging on. look in debugging logs for problems. then you can possibly determine if it is core problem, theme, or plugin, rewrite rules. also determine if it is a problem for all categories or just certain ones. perhaps there is a character in the category name that causes problems if some categories work and others don't.

    The reason I give you these simple troubleshooting steps is because of some of your questions, problems, and solutions.

    Here is an simple example.

    You may provide a question similar to: I live a 100 yards from a store, it is raining, I want to eat breakfast of eggs, but I don't have any eggs, it is raining, how do I get breakfast without getting clothes wet.

    volunteers provide you solutions e.g. Put on rain coat, or use umbrella, go to store, walk to store, buy eggs at store, walk home and cook eggs.

    You then come back with your answer, and say I have no stove to cook eggs, so I put on my bathing suit, swam across a river for 100 yards to reach the store, the store was a clothing store and had no eggs, so I hitchhiked to the airport, and bought my dinner of eggs there.

    sometimes you can solve the problem yourself.

    http://docs.vanillaforums.com/developer/troubleshooting/

    very, very grateful for such good advice, but it http://docs.vanillaforums.com/developer/troubleshooting/ does not help me understand how to fix error. So I asked the community for help.

  • RiverRiver MVP
    edited December 2016

    @kopna said: very, very grateful for such good advice, but it http://docs.vanillaforums.com/developer/troubleshooting/ does not help me understand how to fix error. So I asked the community for help.

    you are welcome, did you follow the advice in my comment and the steps to troubleshoot, and did you test accordingly.

    do you still get error after changing category url name in dashboard categories?
    do you get error on all categories, other category names?
    did you change to the default theme and test?
    what rewrite rules are you using?
    what web server are you using?
    are you using apache?
    are you using nginx?
    are you using iis?
    are you using php 5.6?
    are you using php 7.0?
    did you find errors in your logs?
    did you disable your plugins from dashboard to see if they were causing issue.
    what is the actual url that is giving you the error?
    did you look in your server logs?
    did you enable debugging, did it provide more information?

    answer ALL OF the above simple questions and please reread https://vanillaforums.org/discussion/comment/244744/#Comment_244744

    and so on...

    as explained above.

    if you can't explain what you did, what steps you did and provide answers, you are going to be guessing instead of solving. if you find what is causing error and provide SIMPLE ANSWERS to above questions, you can fix perhaps, or the community can provide you clues.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • kopnakopna Coimbra Portugal ☯

    @River написал:

    @kopna said: very, very grateful for such good advice, but it http://docs.vanillaforums.com/developer/troubleshooting/ does not help me understand how to fix error. So I asked the community for help.

    you are welcome, did you follow the advice in my comment and the steps to troubleshoot, and did you test accordingly.

    do you still get error after changing category url name?
    do you get error on all categories?
    did you change to the default theme and test?
    what rewrite rules are you using?
    what web server are you using?
    are you using apache?
    are you using nginx?
    are you using iis?
    are you using php 5.6?
    are you using php 7.0?
    did you find errors in your logs?
    did you disable your plugins from dashboard to see if they were causing issue.
    what is the actual url that is giving you the error?
    did you look in your server logs.
    did you enable debugging, did it provide more information?

    answer ALL OF the above simple questions and please reread https://vanillaforums.org/discussion/comment/244744/#Comment_244744

    and so on...

    as explained above.

    if you can't explain what you did, what steps you did and provide answers, you are going to be guessing instead of solving. if you find what is causing error and provide SIMPLE ANSWERS to above questions, you can fix perhaps, or the community can provide you clues.

    So all you wrote I did. I already wrote about it. Perhaps you have not read. Or you were not interested.

    here's an example:

    debugging
    */home/*******/public_html/library/core/class.dispatcher.php(326): call_user_func_array(Array, Array) or
    */home/*******/public_html/index.php(44): Gdn_Dispatcher->dispatch() or
    */home/*******/public_html/library/core/class.pluginmanager.php(781): Gdn_PluginManager->callEventHandler(Object(DiscussionModel), 'DiscussionModel', 'BeforeGet', 'Handler') or
    /home/*******/public_html/applications/vanilla/controllers/class.categoriescontroller.php(156): notFoundException()
    [internal function]: CategoriesController->index('News ', '0')
    /home/*******/public_html/library/core/class.dispatcher.php(326): call_user_func_array(Array, Array)
    /home/*******/public_html/index.php(44): Gdn_Dispatcher->dispatch()
    {main}....
    What do I have to do? Do you think that I understand it?

    Sorry, I asked a simple question :(

  • RiverRiver MVP
    edited December 2016

    @River said:

    @kopna said: very, very grateful for such good advice, but it http://docs.vanillaforums.com/developer/troubleshooting/ does not help me understand how to fix error. So I asked the community for help.

    you are welcome, did you follow the advice in my comment and the steps to troubleshoot, and did you test accordingly.

    do you still get error after changing category url name in dashboard categories?
    do you get error on all categories, other category names?

    did you change to the default theme and test?
    what rewrite rules are you using?
    what web server are you using?
    are you using apache?
    are you using nginx?
    are you using iis?
    are you using php 5.6?
    are you using php 7.0?
    did you find errors in your logs?
    did you disable your plugins from dashboard to see if they were causing issue.
    what is the actual url that is giving you the error?
    did you look in your server logs?
    did you enable debugging, did it provide more information?

    ok you provided debug info. in your last comment, was this with default theme and no plugins enabled that you received error. and no apps but vanilla included.

    the problem is here:

    https://github.com/vanilla/vanilla/blob/Vanilla_2.3/applications/vanilla/controllers/class.categoriescontroller.php#L147-155

    and see this

    https://github.com/vanilla/vanilla/blob/Vanilla_2.3/applications/vanilla/models/class.categorymodel.php#L120

    there are still 14 other questions you have not answered. try to read them and answer them.

    also try deleting your cache and turning off your caching in your config.php.

    answer ALL OF the above simple questions and please reread https://vanillaforums.org/discussion/comment/244744/#Comment_244744

    and so on...

    as explained above.

    if you can't explain what you did, what steps you did and provide answers, you are going to be guessing instead of solving. if you find what is causing error and provide SIMPLE ANSWERS to above questions, you can fix perhaps, or the community can provide you clues.

    So all you wrote I did. I already wrote about it. Perhaps you have not read. Or you were not interested.

    I think I've read everything in this discussion, want to try to answer the other questions.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • kopnakopna Coimbra Portugal ☯

    Hi! In fact, the answer here in this hidden - & ( ampersand )

    I just replaced News & Announcements on News and Announcements everything works again.

    Why so I do not know?

    Perhaps this is a bug in the code Vanilla. About like I wrote https://vanillaforums.org/discussion/32893/page-does-not-scroll-down#latest

    Thank you, perhaps you will have your own ideas.

Sign In or Register to comment.