Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Migrating data to local host using XAMPP

arthurIMarthurIM New
edited June 2017 in Vanilla 2.0 - 2.8

Hey There

. I am wondering if I can migrate all the data of
my Vanilla forum to my local host using XWampp .

I have the current copy of my database and the copy of the archives of
the forum . but I am not sure how to configure all inside my local host.

I have apache and I use Mysql admin . All is correctly configured in
regard of Xwamp

The database is imported inside the mysql panel in my local host and
also the data of vanilla forum is correctly updated inside Xmap

But I am not sure how to connect both .

I am a bit noob with that .

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Search through the tutorials, I think there has been some talk on that.

    But it is no hard work anyway...

    • Make sure that you delete all *.ini files in the /cache folder
    • In the /conf/config.php you will find the database settings. Change them to reflect your new online MySql credentials.

    Basically that's everything that is to do.


  • Thank you . I will test it today

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Don't hesitate to ask if you get stuck!


  • Ok . I did that modifications but when I try to load the forum in my local host Localhost:8080/vanilla ( my own configuration) , there are not error message but the load of the website is infinite . ( is like in connecting mode all the time)

    Some possible solutions ?
    Thanks :)

  • Done . One small problem with a typo adding the modifications :) .

    R_J
  • @arthurIM said:
    Ok . I did that modifications but when I try to load the forum in my local host Localhost:8080/vanilla ( my own configuration) , there [url=http://www.shuttle-paris-airports.com/]paris shuttle[/url] are not error message but the load of the website is infinite . ( is like in connecting mode all the time)

    Some possible solutions ?
    Thanks :)

    Hello,
    For my part, it does not cease to make bugs! I probably missed something.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @miranaE114 feel free to share some of those error messages and maybe we can help you solving your problems.


Sign In or Register to comment.