Gopi Activity Comments do not work

This discussion is related to the Gopi addon.

On the user profile page, when this theme is active, clicking "comment" does not bring down a box to reply.

elbination

Comments

  • ZeekZeek New New

    same here haha

  • How can I fix it??

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    We can't help you at all if you don't provide a link and or a screen shot or login credentials to see the problem.

  • @vrijvlinder said:
    We can't help you at all if you don't provide a link and or a screen shot or login credentials to see the problem.

    This is my test site! https://cuongvm.net/vanilla/profile/admin
    You can test with user/password: test/123456

    Besides, this theme also have an issue with the menu. When you add more menu text ( 3 or 4), the nav will be broken.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I would try another theme.. or write the author for help. The comment box shows fine I don't see the problem.

  • @vrijvlinder said:
    I would try another theme.. or write the author for help. The comment box shows fine I don't see the problem.

    I mean The comment box in profile (CommentForm)!

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Make sure you have the correct permissions. Try another theme to see if that gets fixed. If not , disable plugins until you find the cause.

  • elbinationelbination New New
    edited August 2017

    @vrijvlinder said:
    Make sure you have the correct permissions. Try another theme to see if that gets fixed. If not , disable plugins until you find the cause.

    Oh no, I tried disable all the plugins but it's not any affect.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    sorry this is happening to you because of a bad theme... All I can advice is to use a better theme that is compatible with 2.3.1 instead of the theme you are using which seems to be incompatible and the author does not give a shit to help you.. :(

  • zoldoszoldos New New

    I'm having this issue as well with VF 2.6. I love the theme tho. No one knows how to fix this??

  • please, how to fix this problem?

  • FBIFBI

    My forum was fine using this theme with latest Vanilla.
    Would you send a link test to check?

  • AoleeAolee Hobbyist & Coder ✭✭

    suprisingly I'm also having the same issue, doesn't seem to work for me too. anyone manage to find a solution?


  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    It's a either a js or a css problem. Check the JacaScript console to find out which of both


  • AoleeAolee Hobbyist & Coder ✭✭


    Unfortunately developer console doesn't show any javascript error :( . ill try to compare the css with other theme and see how. will update you guys if i find anything.

  • AoleeAolee Hobbyist & Coder ✭✭
    edited July 4

    Found the issue, sharing my quick fix for the benefit of the community.

    /themes/Gopi/design/style.css

    Culprit is this -

    I'm not sure though if this css class ".Hidden" being used elsewhere (it has the "!important")

    For now, I'm gambling to remove it and replace it with the quick patch below.

    modify your style.css

    1) remove the !important from the .Hidden

    2) add the others below

    /** Fix for Actvity Comment - start **/
    .Hidden {
       display: none;
    }
    
    .ItemContent.ActivityComments {
       margin: 0 0 0 45px;
    }
    .Activities ul.DataList {
       margin-left: 45px;
    }
    li.CommentForm form.Hidden > div {
       display: inline-block;
    }
    .DataList.ActivityComments li.CommentForm form.Hidden .TextBoxWrapper textarea.TextBox{
       width: 100%;
    }
    /** Fix for Actvity Comment  - end **/
    
    
    


    R_Jpioc34FBIKaspar
  • AoleeAolee Hobbyist & Coder ✭✭

    it's the css display value locking the comment in hidden state. apply the fix above and it should be fine. see it in action here https://bit.ly/2LJNV1k

Sign In or Register to comment.