Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

localhost install error 2.5

I did a clean install on localhost.. and all i get is the header the logo a few links other then that page not found. if i use 2.3 no issue php 7.1 on zend

Comments

  • I just reverted back to 2.3.1 until a stable release is availble

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    2.5 IS a stable release.

    If you are having issues, you can ask questions here, or file an issue on GitHub.

  • I have hit the same problem, wanted to test 2.5 out so created a fresh database and did a clean install of 2.5, the installation page comes up but once that is completed the redirect goes to a Page Not Found error, as does any other page. The database was populated with tables, but nothing working up front.

    Running XAMPP 7.1.4 on Windows, just accessing via localhost/vanilla25. My old 2.3.1 install at localhost/vanilla works just fine.

  • Update: installing it on a vhost (vanilla.test) improved things slightly, the dashboard works and a few other pages, but not the actual forum pages. I assume it's a rewrite issue? Because the URLS aren't pretty either.

    http://vanilla.test/index.php?p=/activity is a page that works
    http://vanilla.test/index.php?p=/dashboard/settings/home is the dashboard working and where I was first directed after installation.

  • K17K17 Unlosk · Français / French ✭✭✭

    I think you must check if mod_rewrite is enabled because as I know it's not always default enabled with xampp.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator
    edited January 1

    Pretty urls aren't activated by default. You have to add $Configuration['Garden']['RewriteUrls'] = true; to the /conf/config.php

    Your problems might be caused by the htaccess file. Please try this version

    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /.
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    
  • @K17 said:
    I think you must check if mod_rewrite is enabled because as I know it's not always default enabled with xampp.

    Yes it is enabled, I make use of it in other projects and no problems with 2.3.

    @R_J said:
    Pretty urls aren't activated by default. You have to add $Configuration['Garden']['RewriteUrls'] = true; to the /conf/config.php

    Your problems might be caused by the htaccess file. Please try this version

    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /.
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    

    No change WRT htaccess. Adding that line to the config changes the URLs but still 'page cannot be found' on the main page. Activity works, as does the admin page, but not the discussions.

  • There are also no options in the dashboard to create new forums and the Layout selection page is empty.

  • kopnakopna Coimbra Portugal ☯

    @vNerd
    replace the old htaccess file from version 2.3.1 in the upgraded version 2.5

  • @weeniebeenie said:
    There are also no options in the dashboard to create new forums and the Layout selection page is empty.

    it's a bit strange but go to plugins and enable at least one disabled plugin, then the missing options appear.

  • edited January 2

    @Sealord said:

    @weeniebeenie said:
    There are also no options in the dashboard to create new forums and the Layout selection page is empty.

    it's a bit strange but go to plugins and enable at least one disabled plugin, then the missing options appear.

    Hmm yeah, doing that you get the modal that says "Required addon enabled: Vanilla" and now everything works. So it seems the problem is that the vanilla core isn't even enabled for whatever reason.

    Thanks

Sign In or Register to comment.