Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Stuck with an error [RESOLVED]

lorddfglorddfg
edited May 2018 in Vanilla 2.0 - 2.8

Version: Vanilla 2.5.1

I get this whenever I try to click a button in dashboard, because of this I can't use the dashboard :(

modal.js?v=2.4.201:209 Uncaught ReferenceError: Util is not defined
at Modal._getConfig (modal.js?v=2.4.201:209)
at new Modal (modal.js?v=2.4.201:84)
at HTMLDivElement.eval (modal.js?v=2.4.201:460)
at Function.each (jquery.js?v=2.5.1:4)
at init.each (jquery.js?v=2.5.1:4)
at init._jQueryInterface [as modal] (modal.js?v=2.4.201:455)
at DashboardModal.start (dashboard.js?v=2.4.201:464)
at new DashboardModal (dashboard.js?v=2.4.201:371)
at HTMLAnchorElement.eval (dashboard.js?v=2.4.201:1314)
at HTMLDocument.dispatch (jquery.js?v=2.5.1:5)

_getConfig @ modal.js?v=2.4.201:209
Modal @ modal.js?v=2.4.201:84
(anonymous) @ modal.js?v=2.4.201:460
each @ jquery.js?v=2.5.1:4
each @ jquery.js?v=2.5.1:4
_jQueryInterface @ modal.js?v=2.4.201:455
start @ dashboard.js?v=2.4.201:464
DashboardModal @ dashboard.js?v=2.4.201:371
(anonymous) @ dashboard.js?v=2.4.201:1314
dispatch @ jquery.js?v=2.5.1:5
v.handle @ jquery.js?v=2.5.1:5

I have tried removing cache, and I have also disabled all plugins and recently just removed everything and use a fresh install.

So, not sure what's going on. I suspect it's a bootstrap issue.

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Try to find out if this is a bootstrap error by manually editing the /conf/config.php. Find $Configuration['Garden']['Theme'] = 'Bootstrap'; and change it to $Configuration['Garden']['Theme'] = 'default';


    lorddfg
  • @R_J said:
    Try to find out if this is a bootstrap error by manually editing the /conf/config.php. Find $Configuration['Garden']['Theme'] = 'Bootstrap'; and change it to $Configuration['Garden']['Theme'] = 'default';

    $Configuration['Garden']['Theme'] = 'Gopi';
    $Configuration['Garden']['MobileTheme'] = 'bittersweet';
    $Configuration['Garden']['ThemeOptions']['Name'] = 'bittersweet';
    $Configuration['Garden']['ThemeOptions']['Styles']['Key'] = 'Dark Navbar';
    $Configuration['Garden']['ThemeOptions']['Styles']['Value'] = '%s_dark';

    Not using bootstrap though.

  • I switched to default, the error still remains, trying to troubleshoot it :(

  • I FIXED IT.

    Easy fix, to go cloudflare and disable minify and rocketloader.

    And everything works!

Sign In or Register to comment.