Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

New install v. 2.6- Error 404 - Page not found

Hello, i today copy files to ftp.
Next time i go to my domain and i see in url

And Error 404 - Page not found.

I try refresh, clear cachce, next browser.

Version of PHP on my hosting is: 7.1.17

Please help, thank you


  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    Welcome to the community.

    See here for the solution:

  • Thanks, work. I rename .htaccess.dist to .htaccess

  • hi everybody.
    I've tried to update from 2.2 to 2.6 but i get error 500
    I've followed all the suggestion about upgrading
    php 7.1
    empty cache folder
    enabled $Configuration['Debug'] = true;
    disabled all plugins from config.php (HtmLawed included)
    set garden theme to 'default'

    but no result, gives nothing.
    If upload my backup files everything works (vanilla 2.2) but I would like to have the 2.6 version
    deleting the existing .htaccess and renaming .htaccess.dist to .htaccess does not work for me.
    the forum is (was) here:
    any suggestion?
    thank you

    part of my config.php file:
    $Configuration['Debug'] = true;
    // EnabledLocales
    $Configuration['EnabledLocales']['vf_en_EN'] = 'en-EN';
    $Configuration['EnabledLocales']['vf_en'] = 'en';

    // EnabledPlugins
    //$Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    //$Configuration['EnabledPlugins']['SplitMergeFE'] = true;
    //$Configuration['EnabledPlugins']['Example'] = true;
    //$Configuration['EnabledPlugins']['RiceBalls'] = true;
    //$Configuration['EnabledPlugins']['Emotify_RiceBalls'] = true;
    //$Configuration['EnabledPlugins']['ButtonBar'] = true;
    //$Configuration['EnabledPlugins']['Countdown'] = true;
    //$Configuration['EnabledPlugins']['ExtraDati'] = true;
    //$Configuration['EnabledPlugins']['ImageUpload'] = true;
    //$Configuration['EnabledPlugins']['NoCaps'] = true;
    //$Configuration['EnabledPlugins']['ProfileExtender'] = true;
    //$Configuration['EnabledPlugins']['SplitMerge'] = true;
    //$Configuration['EnabledPlugins']['UserList'] = true;
    //$Configuration['EnabledPlugins']['VanillaStats'] = true;
    //$Configuration['EnabledPlugins']['EmojiExtender'] = true;
    //$Configuration['EnabledPlugins']['Emotify'] = true;

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    If possible, check your server logs to see if the issue is identified there.

    You could also check whether the permissions on the Vanilla folders have changed on


    which all need to be readable and writeable. They should be 755 I think.

  • Thank you @whu606
    attached the server error log, I'm not able to understand what is wrong.
    the permission for all the folders are:
    user: read, write, run
    group:read, run
    others: read, run

    log.txt 137.8K
  • R_JR_J Ex-Fanboy Munich Admin

    @bullx: make sure you use the version you can find here and not the zip file from GitHub. Please also make that you have unzipped all files

  • bullxbullx New
    edited May 2018

    @R_J thank you It worked.
    the forum is up and running the only issue is that I can not login.
    The login windows contains a capy of the home page.

    thank you for your support.

  • i've left debug mode on and seem related to: Undefined property: stdClass::$CountAllDiscussions

  • i've done the process again and now everything works.
    thank you very much.

Sign In or Register to comment.