Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Page Not Found

Installed locally on Win 10 with Mamp Pro for Windows

Install went smoothly, control panel works fine. However when I go to visit the forums I get Page Not Found. I searched the forums but could not find a solution.

Also in settings when I go to Layout there are no options to choose from, just a save button.


  • @createsean can you confirm you are using the stable release located here. If you just took it from Github, there are extra build steps:

  • Yes I downloaded the pre-compiled version

  • AdrianAdrian MVP
    edited October 2018

    @createsean can you try these steps:

    Please share any errors you get/see.

  • @Adrian I did the troubleshooting and no dice. The only one I didn't try was running /utility/update cause I couldn't find the upgrade instructions as indicated in the troubleshooting guide.

    Interestingly despite seeing 2.6.3 on the install screen config.php lists the version as: 2.4.201

  • AdrianAdrian MVP
    edited October 2018

    I agree it should be clearer - I’ll make a note to add to see read me. The update instructions are as below from the readme

    Follow these steps to upgrade Vanilla when a new stable release is announced. These instructions assume you're using SFTP to manually copy files to a server.

    Please consider using maintenance mode before running database updates if your database is very large (millions of users or comments).

    Backup your database, .htaccess and conf/config.php file somewhere safe.
    Upload the new release's files so they overwrite the old ones.
    Delete all files in /cache (except .htaccess if you use Apache).
    Follow all version-specific instructions below. It is critcal you delete the listed files.
    Go to to run any database updates needed. (404? See next paragraph.) If it fails, try it a second time by refreshing the page.

  • @Adrian

    I raised this as an issue on Github a while ago:

    I can confirm that the issue is still the same in 2.6.3, and that it is still not possible to enable applications.


    Go to the dashboard and enable any plugin, and the Vanilla plugin should automatically enable.

  • @whu606 I did an open source install for a friend 3 days ago and did not run into this, but thanks for bringng it to my attention. I’ll mention this to Linc on Monday, if he doesn’t see it before...

  • @Adrian

    Could be my setup, I guess, although others have experienced the same issue with XAMPP local installs.

    I'm using XAMPP on a Windows 10 PC.

  • edited October 2018

    @whu606 said:

    Go to the dashboard and enable any plugin, and the Vanilla plugin should automatically enable.

    I enabled 2 plugins: flagging and all viewed, but this did not change anything. I still get page not found.

    Again windows 10 and Mamp Pro for windows.

    -- EDIT --
    Refreshed browser a couple of times and all is good now. Thanks @whu606 and @Adrian

Sign In or Register to comment.