2.0.18.1 upgrade to 2.8.1 - Which versions to jump through?

EntimpEntimp New
edited March 20 in Vanilla 2.8 Help

Hi all,

Firstly many thanks in advance of any assistance.

I am helping a charity export a large forum that has not been updated since 2013 to a new hosting package. Using PhPMyAdmin, I have managed to recreate the forum on the new hosting.

Alas the version is: 2.0.18.1

I understand that the update to the latest version should be done in increments.

Would anyone be able to suggest what versions to cycle through? Or should I use jump stright to 2.1 then 2.3 then 2.5 then 2.6 before finally 2.8 and 2.8.1?

I determined that list of versions from: https://docs.vanillaforums.com/developer/installation/self-hosting/

Are there any guides (I have searched).

Many thanks.

Tagged:

Comments

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    I'd definitely make sure you have everything backed up before attempting to upgrade progressively through the different versions. It's also worth making sure you've upgraded your PHP version too. What PHP version are you running now?

    Personally I think it might be easier (and safer) to do such a large jump as a migration. @CJReese's post might be helpful to you.


  • I have a full SQL file that I used to recreate the forum from the old host. So backup isn't a problem.

    I am running php 7.2.

    I'd just like to know what versions to step through to upgrade.

    I'll have a read of that thread when I havea moment.

    Ta.

Sign In or Register to comment.