Please upgrade here. These earlier versions are no longer being updated and have security issues.

PHP 7.3 error

This discussion was created from comments split from: Vanilla 2.8 is now available.

Comments

  • terhoxterhox New
    edited March 24

    Which PHP version should I use? PHP 7.2 works, however if I choose PHP 7.3 I get "Something has gone wrong."

    Fatal Error in Gdn_Database.Connection();

    An error occurred while attempting to connect to the database

    could not find driver


    New look is awesome!

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited March 24

    @terhox

    I've split this out to its own thread.

    I think there may currently be issues with php 7.3, so maybe stick with 7.2 for now. See this comment by one of the devs:

    https://open.vanillaforums.com/discussion/comment/256100/#Comment_256100

    terhox
  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    It’s worth noting we’ve fixed PHP 7.3 on master. Within the next week all Vanilla developers will be running PHP 7.3 on their development machines and we already have all of our automated tests passing on PHP 7.3.

    We’ve really just been waiting for XDebug to have PHP 7.3 compatibility.

    Vanilla 2.8

    PHP 7.0 - 7.2

    Vanilla 3.0 (next release)

    PHP 7.1 - 7.3

    pioc34terhox
  • I'm running vanilla 2.8->2.8.1 with php 7.3 and did not experience any errors except setting the php rule in nginx...

  • I should say I had to get rid of the rich editor and enable the Advanced Editor.

  • I installed 2.8.1 through cpanel automatic installation. PHP 7.3 I will get error and PHP 7.2 there’s no problems.

    As new community installation I would like to make sure that PHP version is the latest possible.

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    I understand that. It will probably be at least a month before the next official open source release.

    In the meantime you can make your own build from the branch we use for Vanilla Cloud (it’s usually a little ahead). I’m not 100% sure all of the PHP 7.3 made it in but the current branch is release/2019.004.

    If you do take that path though you might find release notes to be a little confusing.

    terhox
  • ShadowdareShadowdare Moderator
    edited March 25

    On my development environment, I'm running Vanilla with PHP 7.3.2 with no problems related to the PHP version.

    When you switched from PHP 7.2 to 7.3, were the same extensions installed along with the same config files? For instance, you would need mysqli and pdo_mysql to connect to a database.

    Add Pages to Vanilla with the Basic Pages app

    terhox
  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    FWIW I think the major PHP 7.3 issues (that were breaking our automated tests) were related to our BBCode formatter.

  • @charrondev @Shadowdare if it's not related to php7.3; why is the rich editor almost unusable. If I cut and paste something; I have no way of editing out the apparent hidden tags in what I pasted.

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    The editor runs in the user’s browser. The posts are rendered in PHP afterwards, but I’m not aware of any differences there in PHP versions.

    If you’re noticing issues while creating a post with Rich Editor, please file it over on our issue tracker and be sure to post your browser/operating system.

    If the issues are related to pasting various characters, sharing the source you are copying from is helpful as well. I’m currently writing integration tests around this so any additional test cases are helpful.

  • Wow, thanks! I switched on nd_mysqli and nd_pdo_mysql PHP extensions, and error gone away 🙂

    But I am aware that there's a new version coming, I think I will test and learn current version and when 3.0 is ready I will go live with that.

    Shadowdarecharrondev
Sign In or Register to comment.