Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

Upgrade to 3.2 from version 2.1

This discussion is related to the Vanilla addon.
stevenlamstevenlam New
edited September 24 in Vanilla 3.x Help

I have a question.

My vanilla version is 2.1.1, is that possible to upgrade directly to 3.2.

Or we must update to each version like 2.2 , 2.3, 2.4 ...

Thánks

Comments

  • So is that possible to install the newest version, and restore database later to avoid All users need to reset their password?

  • Your can start with a fresh and connect old database later - yes.

    But to my understanding it will not change anything.

    Structure update of database is still needed.

    @R_J @charrondev

    I do not know under which circumstances password resets would be required.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Password are saved as hashes so that you cannot recover the password from what is saved in the database. Therefore there is no way to transform the old password into the new one. I hope I can explain it: there has been a Vanilla version where passwords where matched with the old method and afterwards saved with the new "format". Therefore all users who logged in the forum while that version has been used, where ported to that new format without even noticing it. That transformation step isn't there in Vanilla any more. So forum members have to reset their password. There is no way to avoid that.

    But who cares? Write a message: "Heads up! There's a major forum update coming. You will have to reset your password when the update is done". Then your users are prepared.

    After the update show another message "Forum has been updated. Your password has become invalid. Please reset it". The current Vanilla version uses a more secure algorithm. So your users have nothing to complain about.


    stevenlam
  • stevenlamstevenlam New
    edited September 26

    So, I will update 2.1.1 to 2.8 first then 2.8 to 3.2 or 2.1.1 direct to 3.2 ?

    Cause what I saw when download 3.2 version is "Version 2.8 required plus php 7.2"

Sign In or Register to comment.