Something has gone wrong. [RESOLVED]

This discussion is related to the Basic Pages addon.
namjarnamjar New
edited October 2019 in Feedback

When click "All Pages" and "New Page", show us

"Something has gone wrong.

We've run into a problem and are unable to handle this request right now. 

Please check back in a little while."



  • ShadowdareShadowdare Moderator
    edited February 2019

    Thank you for using Basic Pages!

    What version of Vanilla are you using?

    Please add this line to the /conf/config.php file to see details behind the "something has gone wrong" error:

    $Configuration['Debug'] = true;

    Please share the error message details here.

    Add Pages to Vanilla with the Basic Pages app

  • This is the error message I'm getting-

    My Vanilla forum version is 3.2

    417:                 if (!$message) {
    418:                     $message = $ex->getMessage();
    419:                 }
    421:                 trigger_error($message, E_USER_ERROR);
    422:             }
    424:         }

    [sql] 'select p.PageID as `PageID`, p.Name as `Name`, p.UrlCode as `UrlCode`, p.ViewPermission as `ViewPermission`
    from `GDN_Page` `p`
    where `p`.`SiteMenuLink` = :pSiteMenuLink
    order by `Sort` asc'
    [inputParameters] array (
      ':pSiteMenuLink' => '1',
    [options] array (
      'Type' => 'select',
      'Slave' => NULL,
      'ReturnType' => 'DataSet',
    [returnType] 'DataSet'
    [tries] 2
    [try] 0
    [pDO] array (
    [pDOStatement] false
    [state] '42S02'
    [code] 1146
    [message] 'Table \'admin_vanilla.GDN_Page\' doesn\'t exist'
    [ex] array (

  • R_JR_J Ex-Fanboy Munich Moderator

    Have you enabled the application through the dashboard? When doing so some database tables are created and it looks as if they are missing in your installation. Disable and reenable the application to try to fix this.

  • Hello @R_J ,

    Thanks for your reply.

    I tried your solution but unfortunately that didn't work, getting the same error.

    Admin dashboard is working but the forum is not accessible after installing the plugin.

    Thanks for your help.

    Kind Regards

  • R_JR_J Ex-Fanboy Munich Moderator

    Sorry, I don't see any poosible reason for that. Based on the error message, the table GDN_Page is missing from the database, which would only be the case if the enabling of the application failed. Could you please look into your database if that table exists?

  • Hello @R_J ,

    I've just checked and the table is not there, unfortunately, I'm not a developer so I don't know how to create the database table.

    I tried to create the table but there are lots of options to add and I really don't know about them.

    Any help would be greatly appreciated.

    Kind Regards

  • R_JR_J Ex-Fanboy Munich Moderator

    How did you re-enabled it? Through the dashboard?

    Well anyway: if you run, it should be created.

  • Thank you so much for your help @R_J ,

    It fixed the "Something has gone wrong." problem, however, when I click the "new page" or "All pages" in the admin panel then it is showing this page "View not found. The view you were looking for could not be found."

  • And yes, I was enabling/disabling the plugin through the dashboard.

  • R_JR_J Ex-Fanboy Munich Moderator

    Is Basic Pages located in /applications/basicpages?

  • No, its not there, should I create the "basicpages" folder in the applications?

    Thank you so much for your help.

    Kind Regards

  • My bad, I'm really sorry, I was doing it wrong from the beginning, I had uploaded the module in the "Plugins" folder and that's why it was not working.

    I've uploaded it in the "applications" folder and everything is working fine now.

    I appreciate your patience to help newbies like me.

    Kind Regards

Sign In or Register to comment.