HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

What version best for PHP 5.6?

Hello, We have this one server at the office, and we currently trying to find a simple solution for bulletin board / forum for internal use. I Understand the lastest version runs only on Php 7... So I was wondering if vanilla has an older version that we can use.

The reason we can't upgrade to version 7, is because we have several old programs still dependant with php 5.6. And these programs are crucial to our office productivity. Thanks you :)

Comments

  • Just search for one dollar hosting, php 5.6 is old, unsupported and insecure. As is the old version of forum software that you are contemplating using.

  • charrondevcharrondev Developer Lead (PHP, JS) Montreal Vanilla Staff

    None. PHP 5.6 is a massive security hole. The older versions of Vanilla that still run on it are unsupported, insecure, and many new addons will not work with it either.

    I'd highly recommend spinning a small separate server on a cheap hosting provider and using the latest supported PHP versions so that you can use recent versions of Vanilla.

  • Thanks for the response, I think hosting it on a separate server with php 7 is the solution.

    charrondev
Sign In or Register to comment.