HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Vanilla Theme Apply Problem PLease Help

This discussion is related to the Bootstrap addon.


  • add 'Type' => 'theme', to the $ThemeInfo['bootstrap'] array in about.php

    grep is your friend.

  • @stackmouse said:
    The bootstrap folder should be "/themes/Bootstrap", with a capital B.

    If it isn't, rename it and delete cached theme files from /cache/

    This absolutely worked for me. Remember to delete the cache files after renaming the folder, all should be fine. Thanks

  • manticore789manticore789 Australia New

    Clearing the cache and renaming to capital B is all good and well, but the way to get Bootstrap up and running is this:

    Force the loading of both the theme and mobiletheme to 'Bootstrap' in your config file.

    $Configuration['Garden']['MobileTheme'] = 'Bootstrap';

    $Configuration['Garden']['Theme'] = 'Bootstrap';

    Setting the Theme (desktop) to Bootstrap is important because it will create the Theme Options, so you can interchange between Bootstrap styles (ceruluan, darkly etc).

    If youu enter the MobileTheme only in your config file, it won't work.

    Theme Options will drive changes to both the desktop and mobile themes. It's not one or other other, which is great, unlike some other older themes.

    I can confirm it looks great on Version 3.1. I run Pockets, and a load of other plugins, and so far everything looks in tip-top shape.

    i have found two issues, one is a configuration issue which I may have stuffed up, the other is a visual one based around the discussions page template file (more about visual real estate). So I may need to get back to the Dev on that one for some guidance.

    Good luck, if I can do it (a newbie), then you guys can too.

  • This worked for me on Vanilla 3.3. A thousand thank-yous!

  • manticore789manticore789 Australia New

    @tone74 that's great. :)

Sign In or Register to comment.