HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Where do I find "Vanilla ACP » Appearance » Message" In Current Version?

Hi all. Firstly thanks for the software and community. I've been testing and I'm thinking of deploying to my site. My only major issue so far is finding this in the current version. I'm running chat using Blab and it has instructions for Vanilla 3 integration - I've just not been able to find this in the current version. I've done searches online for adding custom iframe with little results available for persons with limited programming/php/etc type of experience. I did see some answers but it's over my head. Is there any way to easily get this done?

Logging into the ACP does not show MESSAGE in the APPEARANCE section, and checking the PHP files I'm not seeing anything that suggests adding iframe. I've managed to set up CHATWEE but I'd rather use the software that's hosted on my own server.

Hoping to add more gamification things to the forums as things progress - and hopefully the upgrades will be smooth going forward.

Thanks in advance. Keep up the good work!

Tagged:

Best Answer

  • R_JR_J Ex-Fanboy Munich Admin
    Accepted Answer

    Go to Moderation / Site / Messages

    khat17

Answers

  • R_JR_J Ex-Fanboy Munich Admin

    Whenever you want to add some html, I'd suggest looking if the Pockets plugin will suit your needs. If you could post a link to where that Vanilla integration is described, we might be able to give better support

    RobertRem
  • khat17khat17 New
    edited July 7

    Thanks for your reply. The content is from the BlaB! website. However the specific documentation is on a member only section of the site. What I can show which is related to what I asked is below.


  • R_JR_J Ex-Fanboy Munich Admin
    Accepted Answer

    Go to Moderation / Site / Messages

    khat17
  • Thank you very much for that! Got it now - however the chat doesn't work. I expect that's an issue with BlaB! and not with the update forums. Maybe incompatible? Not sure.

    There are some other prerequisites to getting it working. Tests on that have passed since it logs in the forum user automatically to the chat. The URL for the chat works with the users, but the iframe doesn't show the chat window above the discussion page.

    Full code:

    <iframe src="PATH_OR_URL_TO_BLAB/index.php" border="0" frameborder="0" style="width:100%;height:400px;border-width:0px"></iframe>
    

    Instead of the chat I'm just getting that blue area above the discussion.

  • R_JR_J Ex-Fanboy Munich Admin

    If this is a test forum, I'd suggest to copy that line somewhere in the default.master.ppl of your current theme temporarily (!) just to try out if this is a Vanilla or a chat problem. Check your browsers network and JavaScript inspector for further hints

    khat17
  • Many thanks @R_J - I managed to get it working by using the "pockets" feature. Added the code there and set the option for it to only be visible when users log in. Had to do that since BlaB! kept redirecting to the main site for some reason....but - it's up and running. Time to go live - many thanks!

    R_J
Sign In or Register to comment.