Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

PLEASE Help me install V2 on Godaddy...

edited December 2009 in Vanilla 2.0 - 2.8
I have been trying to install V2 on Godaddy for several days, tried everything but it wont work.
Can someone here help me with the installation?


  • Options
    create a file called info.php and put in it <? phpinfo(); ?> then pm me the url because PDO might not be enabled
  • Options
    Sorry but how to send PM here??
  • Options
    Anyw, i checked looks like PDO thing is on.

    PDO support enabled
    PDO drivers sqlite2, sqlite, mysql
    PDO Driver for MySQL, client library version 5.0.45

    PDO Driver for SQLite 3.x enabled
    PECL Module version (bundled) 1.0.1 $Id: pdo_sqlite.c,v 2007/12/31 07:20:10 sebastian Exp $
    SQLite Library 3.3.7

    Anything else i check??
  • Options
    1) hiver over inbox and click new conversation then enter my name
    2) what is the url of the info page if you pm me the account details i can have it set up in less than 10 minuites but you have to trust me :S
  • Options
    LincLinc Detroit Admin
    @vflix Huh? It says he has PDO already.

    @vuzer Are you getting an error message? Can you describe the problem you're having?
  • Options
    edited December 2009
    @Lincon This is what it looks like when i enter the site:


    Im no Godaddy so it may have something to do with the paths to the sub domain.

    @vflix i have sent you the link via PM
  • Options
    viflix where did you go? Hope you can find that 10 min to help me. I would really appreciate you help.
  • Options
    LincLinc Detroit Admin
    @vuzer I think this is a recurring issue with Vanilla and GoDaddy hosting. It's possibly related to this:
  • Options
    Any chance some one with technical skill can help me test the installation.
    I can provide all the logins and database info for the installation.
  • Options
    Try putting the following in your .htaccess file:

    Options -MultiViews

    So it should look like:

    Options -MultiViews <IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php/$1 [QSA,L] </IfModule>
  • Options
    edited December 2009
    I tested to add the first like, but it only loads the text seen on screen shot above and the url changes to:
  • Options
    Any other suggestions? I still get the "No input file specified."
    I contacted godaddy support but they will not help me :-(

    Thank you for contacting Online Support. Unfortunately we are not able to provide the most recent version of vanillaforums at this time. We release updates on our system once they have passed our security testing.

    Link to php info:

  • Options
    Hi @vuzer - The "No input file specified" error is likely to be caused by a Apache / .htaccess configuration error as its an error message thrown by the PHP CGI engine, so this error is technically outside of Vanilla.

    Having a quick Google, people seem to have success with other packages by "tweaking" their .htaccess file. Maybe try deleting everything in it and changing it to:

    Options +FollowSymLinks Options -MultiViews RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php/$1 [QSA,L]
  • Options
    Thanks, but still same "No input file specified."
    Do i need to do anything else after editing and uploading the .htaccess ??

    Can you link to the info your have googled?
  • Options
    Hi @vuzer - I just did a generic search;q=godaddy+htaccess+"no+input+file+specified"&amp;meta=&amp;aq=f&amp;oq=

    And looked for pointers... Obviously you'll need the RewriteCond's from Vanilla, as they are specific to this project. Unfortunately I cant assit more, its been a good few years since I've used shared hosting and a LAMP stack. I have a test box running here in a virtual machine that runs CentOS and it works perfectly, however, I have full control over Apache and PHP configuration and its not on a locked down shared host.

    Only other thing I can suggest is that you have setup read/write permissions to the /cache folder and /conf/config.php file/folder.
  • Options
    thank you for your suggestions.
    I have set the permissions to 777 but still same thing...
    Im very close to giving up on this...
    i just hope V2 will be released via godaddy connection....
  • Options
    Sorry i was away on my holes just got back been promoted to mod as i said sorry i can not help you the only thing that i can think of is swapping host to host to try and find one thats how i found mine :D
  • Options
    which host are you running v2 on?
    moving domain and host will cost few bucks you know...
  • Options
    edited January 2010
    @vuzer - I came across a problem today where it wouldnt install, simply adding a "RewriteBase /" fixed the problem... So try changing the .htaccess to:

    <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php/$1 [QSA,L] </IfModule>

    Not sure it will cure your problems! Obviously, make sure when you are editing the .htaccess file make sure your not using Notepad or Wordpad on Windows that is going to be putting in CRLF's.

    If you can get access to your HTTP error log, that might give you clues as to whether the .htaccess is formatted correctly and its implementing rules correctly.
  • Options
    Thanks, but still same thing.
    No input file specified.

    Im editing files in Notepad++ in ANSI format.

    Im on godaddy, how to check HTTP logs?
Sign In or Register to comment.