Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

an error where i install the v2

edited January 2010 in Vanilla 2.0 - 2.8
i downloaded the code from github,and uploaded to the root with the domain "",and then i visited the domain "" for installing v2,but i jump to,and shows "No input file specified. ", so what should i do ? thanks


  • LincLinc Detroit Admin
    edited January 2010
    That means the PHP file it's looking for doesn't exist; that's a "file not found" error, not a Vanilla error.

    When I go to it shows something that doesn't appear to be Vanilla. Are you sure you're uploading it to the correct location?
  • Yes, I uploaded all files that I downloaded from github to the , and that I visit for installing it,but it and shows "No input file specified. ",please visit again,and you will know what I said,thx
  • by the way, i got the source code from here "" - and click download source and choose .zip type,am I right?
  • LincLinc Detroit Admin
    edited January 2010
    Yes, you got it from the right location. No, it's still not really a Vanilla-related issue.

    Is it your server? This points to a problem with your server configuration. Whoever your host is you would do best to contact them regarding this problem.

    The best I can do is suggest Googling "No input file specified" and start chipping away at the myriad possible causes. It could be that you need to disable MultiView in htaccess, that SCRIPT_FILENAME isn't set, or one of several other problems. Sorry, I'm not finding any better leads on how to go about solving this.
  • @beenhua - I had issues with an install on a server for a friend. Changing the .htaccess file to the following cured it for me:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php/$1 [QSA,L]

    It may be a bit of trial and error depending on your hosts setup.
  • LincLinc Detroit Admin
    Ah, @benno is back in town! :)
  • @Lincoln - Cant get rid of me that easy, I'm like a bad smell! :)
  • @Lincoln it is not my server,i buy the hosting from,I will try to contact the godaddy support for this question.
  • @benno thanks for your help, and i tried your code ,but it still does not work, you can see
  • Here is another thread that reported issues with GoDaddy hosting which unfortunately remains unsolved:

    Must be something strange about their setup... I'm kind of thinking its something to do with mod_rewrite on their servers but I'm not that clued up on Apache to offer more suggestions.
  • you can see the phpinfo on this server

    and i had emailed to the godaddy hosting service,and waiting
Sign In or Register to comment.