HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Git, GitHub and Windows users

edited April 2010 in Vanilla 2.0 - 2.8
One of the difficulty of getting started with Git on windows is setting up ssh and a private/public key for authentication. With Git 1.7 however, you can use https for authentication and GitHub now support it:


If all the that ssh stuff put you off Git in the past, you should try again.

Try Git Extensions to install Git:

(Git Extension only include Git 1.6.5)


  • lucluc ✭✭
    At last, I'll be able to use git as well from work instead of just mercurial.
  • I'm going to have a go with Tortoise Git and see how I do.
  • What ever you use, make sure it install msysgit 1.7+.

    You might be able to install the correct version yourself (I did it for git extensions) but I am not sure your GUI will be able to clone or push to GitHub using the new protocole if it doesn't include the correct version by default.
  • *sigh*I can read the docs :P

    But thanks for mentioning that anyway, it's very kind :)

    I've got the latest versions installed, just haven't had a chance to reboot. I wish the installers would just include the explorer restart routine that dropbox does and ave me the reboot :/
  • LincLinc Former Staff Detroit Admin
    That's the link I've used thus far :) Haven't had much trouble with it on Windows.
  • Yeah, well I have :P

    It just wouldn't work for me. I finally got things working by using the Putty GUI to create my public and private keys. I've yet to make a push, but if I'm successful I'll try my method again in a VM and if I can remember/get it to work again I'll see if I can make some time to post up a graphical step-by-step walk-through.
  • SS ✭✭
    Nothing works for me :(
  • LincLinc Former Staff Detroit Admin
    What error are you guys running into?
  • I don't remember 100% from memory, but when right clicking on a directory and attempting to clone a git repository into that location, the TortoiseGit GUI was bitching about the key that I'd created, using the bash command line, not being valid.

    Using the key created inside the Putty GUI worked fine, but it did take a bit of trial and error to get that far.
  • LincLinc Former Staff Detroit Admin
    edited May 2010
    Oh, see, I don't use any GUIs. I just stick to the Git bash in msysgit and haven't run into any problems except config errors on my part.
  • Most gui don't suppose the new authentication scheme. However you can the command line to deal remote commands (git clone, git pull, git push) and use gui to commit locally.

    When trying https auth on windows, I add an issue with ssl certificate verification:
    Welcome to Git (version

    [email protected] c:/Users/damien/Documents/dev/
    $ git clone https://[email protected]/dinoboff/Garden.git
    Initialized empty Git repository in C:/Users/damien/Documents/dev/
    error: error setting certificate verify locations:
    CAfile: /bin/curl-ca-bundle.crt
    CApath: none
    while accessing https://[email protected]/dinoboff/Garden.git/info/refs

    fatal: HTTP request failed
    I don't know what is the problem, but you can disable it:
    [email protected] c:/Users/damien/Documents/dev/
    $ export GIT_SSL_NO_VERIFY=false

    [email protected] c:/Users/damien/Documents/dev/
    $ git clone https://[email protected]/dinoboff/Garden.git
    Initialized empty Git repository in C:/Users/damien/Documents/dev/
    remote: Counting objects: 10301, done.
    remote: Compressing objects: 100% (4128/4128), done.
    remote: Total 10301 (delta 7349), reused 8621 (delta 6033)
    Receiving objects: 100% (10301/10301), 2.62 MiB | 531 KiB/s, done.
    Resolving deltas: 100% (7349/7349), done.
    Checking out files: 100% (614/614), done.

    [email protected] c:/Users/damien/Documents/dev/
    To make it permanent:
    git config --global http.sslVerify false
  • Thank you Dinoboff!!

    I am also having the exact same issue and your workaround (GIT_SSL_NO_VERIFY=false) solved it!

    I wonder though, what is the root cause and how to solve it properly...
  • Thanks the GIT_SSL_NO_VERIFY=false was just the quick fix I need. I'll figure out the real cause someday when I have "free" time.
  • I just can't get the hang of Git.

    I managed to set up a Mercurial server with hgweb on my readynas though, been moving all of my projects out of svn over to hg... so nice.

    Not advocating vanilla move or anything, but was hg ever a consideration when choosing hosting? Just curious about the reasoning behind the choice.
  • LincLinc Former Staff Detroit Admin
    It's what all the cool kids were doing.
  • ddumontddumont ✭✭
    edited April 2011
    I've seen those... I was curious about the vanilla ppls experiences with git and if they considered any others before deciding on git.

    I've used all kinds of SCMs. At work we primarily use Rational ClearCase and Rational Jazz. I've primarily used svn for my own projects until recently I had need to do something that dscm's handle very well and svn does not.

    My frustrations with git lead me to try out mercurial and, for me at least, it was much easier to understand. The eclipse integration points are also much more polished than the git ones.

    I'm not trying to troll, because I have no vested interest in anyone using any particular scm but myself. I was just curious to see what others' experiences were. :)
  • I ended up never trying Mercurial because GitHub is so good, that made me pick Git over anything else. I wasn't really int he market for setting up a server, so GitHub sold me on it.

    Git was very rough until the end of last year on Windows, but the last time I installed it, it seemed pretty straight forward... for me, GitHub is Git, and BitBucket just seems like a horrible mess in comparison. Strange that the "complex" tool has an "easy" web service and vice-versa.

    Integration with other systems wasn't a concern for me since I do everything in npp still - not because I think it's cool, I just "haven't had time" to get used to an IDE. Git is also my first entry into VCS, so yes, initially it confused me somewhat :D
Sign In or Register to comment.