Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Rss feed url?

Hi people,

I want to show the recent posts/discussions of my forum with an rss feed, but what is the rss feed url of my forum?

Thanks

Comments

  • Options
    By the way.. I'm using vanilla 2.
  • Options
    oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    edited June 2010
    @Alexander25 it should be: http://yoursite/discussions/feed.rss

    Most recent Webbrowsers show you a RSS-Button if a RSS-Feed is being found on the page. You can check this in the Source of your page when searching for
    type="application/rss+xml"
    (In my Vanilla 2 RC2 Installation, this is one of the very top lines on the Discussions page)
  • Options
    Great! Thanks alot!
  • Options
    Hi again.

    I can't get it working.

    The link is http://www.betexcellence.com/community/discussions

    and I can see the rss button, but if I press the button I get an error. Maybe you could please tell what might be wrong?

    Thanks
  • Options
    TimTim Operations Vanilla Staff
    This is a known issue and we're looking into how best to fix it. Sorry :/

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Options
    Any news on this one?
  • Options

    Is this still broken or am I doing something wrong?

  • Options

    ^^ Ditto. Seems to still be a problem (View not found) when clicking on the rss icons which are available by default next to categories?

  • Options
    hgtonighthgtonight ∞ · New MVP

    @mattchatterley‌ I am not seeing this issue on 2.1. What version are you using?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    @hgtonight 2.1 as well - very odd, but good to know it works for someone else therefore it's either because of my installation (unlikely?), or my custom theme (more likely!) - the URL being generated checks out, but it seems like the template for the feeds is missing - will be investigating more as soon as I've ticked a couple of urgent items off the todo list!

  • Options
    hgtonighthgtonight ∞ · New MVP

    @mattchatterley‌ revert to the baseline+ theme and verify it doesn't work there.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    peregrineperegrine MVP
    edited June 2014

    @mattchatterley said:
    hgtonight 2.1 as well - very odd, but good to know it works for someone else therefore it's either because of my installation (unlikely?), or my custom theme (more likely!) - the URL being generated checks out, but it seems like the template for the feeds is missing - will be investigating more as soon as I've ticked a couple of urgent items off the todo list!

    Yes, try a different theme, and or disable plugins one by one to see if it improves.

    do you get something like this when you click on feed buttons when debugging.

    if so check your plugins and themes and the files in conf/folder

    e.g.

    if you have a blank line before the opening php in any file (not good)
    
    `<?php if (!defined('APPLICATION')) exit();`
    
    
    or a closing ?>  at the bottom of file  (not good)
    
    ?>  at the end of any file in a plugin  you will break the rss feeds.
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Alas, doesn't work with Baseline+ either, I get "Whoops! View not found.", with the following debug output/trace:

    Trace

    0 /var/www/hive.cbscustomerservices.com/library/core/class.controller.php(898): NotFoundException('View')

    1 /var/www/hive.cbscustomerservices.com/applications/vanilla/controllers/class.categoriescontroller.php(270): Gdn_Controller->FetchViewLocation('helper_function...', 'categories')

    2 /var/www/hive.cbscustomerservices.com/applications/vanilla/controllers/class.categoriescontroller.php(122): CategoriesController->All()

    3 [internal function]: CategoriesController->Index('general', 'feed.rss')

    4 /var/www/hive.cbscustomerservices.com/library/core/class.dispatcher.php(350): call_user_func_array(Array, Array)

    5 /var/www/hive.cbscustomerservices.com/index.php(46): Gdn_Dispatcher->Dispatch()

    6

    and

    ViewLocation(): array (
    0 => '/var/www/hive.cbscustomerservices.com/themes/default/views/categories/helper_functions_rss.tpl',
    1 => '/var/www/hive.cbscustomerservices.com/themes/default/views/categories/helper_functions_rss.php',
    2 => '/var/www/hive.cbscustomerservices.com/applications/vanilla/views/categories/helper_functions_rss.tpl',
    3 => '/var/www/hive.cbscustomerservices.com/applications/vanilla/views/categories/helper_functions_rss.php',
    )

  • Options
    peregrineperegrine MVP
    edited June 2014

    in applications/vanilla/controllers/class.categoriescontroller.php(270):

    what does it say at line 270

    does line 270 say

     include_once $this->FetchViewLocation('helper_functions', 'categories');
    

    not sure why it is looking for helper_functions_rss - did you modify anything in the core?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    It's:

    include_once $this->FetchViewLocation('helper_functions', 'categories');
    

    Which seems to be right.

    library/core/class.controller.php seems to add the _rss (in the definition of FetchViewLocation), so I'd assumed that was the right behaviour and the files are just missing.

    Definitely haven't modified anything in core! :)

  • Options

    I don't know why its doing that

    just for a n experiment you could clone a copy

    applications/vanilla/views/categories/helper_functions.php

    to

    applications/vanilla/views/categories/helper_functions_rss.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.