Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Invite Friends

This discussion is related to the Invite Friends addon.
Invite Friends

Comments

  • This extension is broken with 1.1.2?
    All I get is a blank page :-(

    Posted: Tuesday, 13 March 2007 at 2:28PM (AEDT)

  • I just looked at this to see if I could help. Here is what I did to get the form to display.

    At the top of the default.php, I made it look like:
    if (!defined('IN_VANILLA')) exit(); include($Configuration['APPLICATION_PATH'].'extensions/InviteFriends/config.php'); //include('config.php');
    Then I change the Render_ValidPostBack function to look like:
    function Render() { //_ValidPostBack if ($this->IsPostBack) { include('extensions/InviteFriends/template.php'); } }

    I think that should get you going.
  • Thanks jimw that got the form to actually show up!

    Thank you!
    Your Invitation was sent to 2 friend(s).
  • this is not working, i cant see it in extensions.... to activate it... is not being recognized by vanilla....
  • Hi,

    When I'm signed out and viewing someones profile I get the following at the top of the page:

    Notice: Trying to get property of non-object in /home/.pilar/vbunet/xxxx.com/forums/extensions/InviteFriends/default.php on line 59

    Notice: Trying to get property of non-object in /home/.pilar/vbunet/xxxx.com/forums/extensions/InviteFriends/default.php on line 60


    But when I'm logged in the errors vanish. Do you know how I can get rid of these errors?
  • The extension "private accounts 1.0" prevents "Invite Friends 0.3" from working.

    I've tested this, and turning "private accounts" extenstion on and off enables and
    disables "invite friends".

    Any clues or hints?
  • Is this AddOn working well for anyone on Vanilla 1.1.4?

    It looks like from the comments above that jimw's fix will get it working, but I wanted to confirm with someone who is using it successfully before giving it a try. Thanks..
  • can someone just upload a fixed version of this?
  • umm i just took off private accounts and invite friends still did not work
  • yup works as it should with jimw correction. even with the private accounts ext. installed
  • I've added all the files inside the mail folder into the extensions directory as instructed.
    Activated it, however it will not show-up in the links or control panel.

    Please Help.
  • It did show up in the accounts section of the user-page, however when i click on the link nothing happens, simply a blank page.

    Please help.
  • solution posted by "jimw on Mar 25th 2007" works fine.
    but this add-on is competing with another add-on I installed ie "DeleteUser" on the url "...vanilla/account.php?PostBackAction=InviteFriends".
    "invite" button of this add-on is almost next to the header of DeleteUser without any lines breaks...
    I don't know why the DeleteUser functionality even appears on this page. I'm a noob. can someone help?
  • jimw

    Your solution works. Thanks ;)
  • Does anyone have a GUI of what they've configured theirs to look like?

  • hgtonighthgtonight ∞ · New Moderator

    @dougiemac Welcome to the community!

    This plugin is for Vanilla 1 which is no longer supported in this community.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Sign In or Register to comment.