HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Tinymce

This discussion is related to the Tinymce addon.
Tinymce
«1345

Comments

  • I installed TinyMCE and it's nice, except when I want to use Unicode accented characters it replaces them with question marks. How can I change this?
  • look on tinymce forum for an answer http://tinymce.moxiecode.com/punbb/search.php?search_id=1336026868
  • Well actually I did that, and TinyMCE is set to utilize UTF-8 encoding by default. I just did a test, turning off TinyMCE and guess what, the problem persists.

    So something has changed in Vanilla since 1.0.1 that turns accented characters like this--itarataś cārtheṣv abhijñaḥ svarāṭ--into question marks. Any idea what that might be? Is Unicode turned off in the header or something?

    DBH
  • well if u look at the header unicode is not there. I do not know how to enable it u should search this forum for it
  • I can't seem to get Vanillacons to work with TinyMCE. Is this expected? Any chance TinyMCE will come with some prepackaged smilies as well?
  • Hi, I'm trying to install this feature but I'm have no luck. I activated it in the 'Extensions' area, is there anything else I need to do? Do I need to use a specific style perhaps?
  • Read the readme.
  • Will this help you Its how to add language packs to tinymce http://wiki.moxiecode.com/index.php/TinyMCE:LanguagePack
  • Uploaded version 1.1 of Tinymce WYSIWYG editor.
  • Smilies added to the new version
  • Wow. That is fast. Thanks MySchizoBuddy! Another thing I noticed is after installing TinyMCE is that the line breaks in all the previous posts on the forum are missing. So any posts posted before TinyMCE has all the lines now run together. I supposed this is inevitable right?
  • no, it is because you were using html formatter that convert the new line in
    . The formatter use with this extension doesn't.

    First, Schizo, you change the way the extension force the use of its formatter. Replace line 120:$Context->StringManipulator->Formatters = array(); $Context->StringManipulator->GlobalFormatters = array(); $Context->Configuration['DEFAULT_FORMAT_TYPE'] = "Tinymce";
    with if ( $Context->Session->UserID > 0 && $Context->Session->User->Permission('PERMISSION_HTML_ALLOWED') ) { //Make Tinymce formatter the only formatter available to post a new comment or to edit an old one $Context->Configuration['DEFAULT_FORMAT_TYPE'] = 'Tinymce'; $Context->Session->User->DefaultFormatType = 'Tinymce'; $Context->Session->User->Preferences['ShowFormatSelector'] = 0; }
    the old post will still use the previous formatter.

    Then if you want to change the line by
    , not that interesting with WYSIWYG, you can set tinyMCE to do it (I think i read it in the doc) or add a nl2br function in the new formatter.
  • Tinymce by default disables nl2br
    stating that paragraphs should be used instead not br tags
  • Or you could use AutoP.
  • @ MySchizoBuddy:

    I agree,
    But still, you should change the way you force the use of your formatter. Until the are edited with tinyMCE, old post should be using the previous formatter, especially if the forum was using something else than a html formatter.
  • Thanks Dinoboff, Your suggestion works perfectly!
  • @ MySchizoBuddy:
    why the Tinymce editor bar cannot show in IE?
    But it can worked in firefox.
  • whats ue site
  • sorry, only use it in internal
  • In default.php Extension Name: Tinymce

    On this site Tinymce WYSIWYG editor.

    Can we get this updated please?
Sign In or Register to comment.