Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.




  • Options
    Quote: MightyMango
    pic Avoids the need to make changes to your .htaccess files or use mod_rewrite. pic
    All the extensions that purport to change the default page fail for me. I have had to use a combination of methods including changes to my .htaccess file.

    Posted: Friday, 28 September 2007 at 6:16AM

  • Options
    Dexter, sorry that you are having problems and not sure why you are not being redirected to categories.php. It's a long shot but did you sign-out and then in again? Just tested again on our site and am being correctly redirected to our blog page. Just checked with categories.php and that seems to be working too.
    • Are you already using any of the methods that use .htaccess to change the default page?
    • Did you just enter the page file name i.e. categories.php not The code that checks the page exists will not work as it stands if you enter the full URL
  • Options
    thanks for your help. I am not using any other kind of method to set a default page. And yes its categories.php that I did enter. Its a little bit weird, once I am logged out I will be redirected to the category page. After logging in again I end up at the category page, so everything is fine, but after beeing the first time in the discussion section, it doesn't work out anymore. I type the url and will end up at the discussion page. Maybe thats how it supposed to be... This is my test forum Cheers Dex By the way, maybe we can provide an exporter from wbb 1.1.1 to vanilla soon.
  • Options
    "Does it have a trailing '/'"
    Yes it does.
  • Options
    That's the exact behaviour I observe on all the Vanilla installations with this extension and others supposedly able to set a different default page.

    The first time there it takes you to a different default page, usually Categories but every time after that it's right back to discussions, with or without the trailing slash.

    Maybe a cookie is being set the first time? pic

    Posted: Saturday, 29 September 2007 at 10:04AM

  • Options
    Dexter, just realised that there is a problem with DefaultPage if your forum is not in the root of your domain e.g. I'm away from home at the moment but will fix this as soon as I get back.

    In the meantime you could try changing line 87 to:

    header('Location: '.$Configuration['BASE_URL'].$DEFAULT_PAGE);

    Wanderer it does work but not in the way you might think. DefaultPage directs you to your default page when you first access the forum or sign-in, it then sets a session variable to say that the redirection has been done and continues as normal i.e. it ignores the DefaultPage setting until you sign-out. This is by design.

    The idea of DefaultPage is that it directs the user to a particular page when they first arrive. I agree that it is not possible to get DefaultPage to behave in the way you have your forum setup i.e. with a 'Home' button and you are correct in saying that if you need this type of behaviour then you will probably need to use mod_rewrite etc.

    It will be possible with the next version of DefaultPage to set a different starting page for different roles.
  • Options
    OK, that clarifies things then, now that we understand the expected behaviour we can say it works!

    Maybe you should call it: DefaultPageOnceOnlyPerVisit!

    Posted: Saturday, 29 September 2007 at 9:08PM

  • Options
    But 'DefaultPageOnceOnlyPerVisit' isn't very snappy is it :)

    Perhaps it should have been called StartingPage....

    I've not given up yet though. Think I have a way to reproduce the behaviour you have been able to produce with mod_rewrite etc. Have been able to do it with a combination of DefaultPage and Page Manager. Just need to combine everything into DefautlPage.

    Watch this space! ;-)
  • Options
    Uploaded version 1.0.0 of DefaultPage.
  • Options
    The new version (1.0.0) no longer includes the work around for the error message mentioned above.

    Notice: Undefined index: CssClass in /forum/themes/people_banner.php on line 5

    If you experience this problem then just deselect the 'Return to the current page...' option on the DefaultPage settings page.
    It is not necessary to select a 'default page' for this to work.

    Thanks to Dexter and Wanderer for pointing out problems and shortcomings in the earlier versions which I hope have been fixed and addressed in the new version.
  • Options
    Uploaded version 1.0.1 of DefaultPage.
  • Options
    Uploaded version 1.1.0 of DefaultPage.
  • Options
    sweet, thanks.
  • Options
    Uploaded version 1.2.5 of DefaultPage.
  • Options
    Version 1.2.5 fixes a problem where pages created with PageManager were not being displayed.
  • Options
    Warning: Unknown: write failed: No space left on device (28) in Unknown on line 0 Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0
  • Options

    Not sure why you have posted this error here. Do you think it is related to the DefaultPage extension?

    DefaultPage does not use any session variables. I have had this problem myself however (unrelated to Vanilla). It was caused by the 'Temp' folder not being flushed correctly.
  • Options
    I am still not able to get this to work with pagemanager. Goes to a blank page when i use a page made with pagemanager.
  • Options
    any idea on how to make the default pages urls accessible from outside the extension? with the blogger theme, each page sets a link to the discussions page, and i'd like to set this link to my default page thanks in advance
  • Options
    ok, done!
Sign In or Register to comment.