HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

User Info

This discussion is related to the User Info addon.
edited February 2008 in Vanilla 1.0 Help
User Info
«1

Comments

  • oh snap...
  • Uploaded version 1.1 of User Info.
  • Fixed a javascript error occurring when a 'Whisper Back' link was present.
  • Uploaded version 1.2 of User Info.
  • Now displays the username if first & last name can't be found.
  • that is pretty cool
    good job
  • Will it work with the Delbat theme?
  • Well I think the add-on says Vanilla Default theme only because it hasn't been tested with anything else. For another theme, it should only require some Javascript tweaking. Try it and see what happens. If it doesn't work then point me in the direction of a live site using that theme and I'll do some tweaking.
  • Uploaded version 1.3 of User Info.
  • I'm really confused as to why this won't work for me. I even booted into Parallels to run IE7 to see if it worked in that with no luck. I'd really love this addon especially if it could work with MultiRoles.

    http://yoshi.frogspawn.org/~marrow/vanilla/ is my site if you'd be kind enough to figure out why it isn't working.
  • Hmm... I have no idea why it's not working for you. Could you go into the UserInfo folder and open up userinfo.js in a text editor. If you add 'console.log(ln)' after line 13 (without the quotes), that will help me debug the situation. And I didn't know it didn't work with MultiRoles?
  • Line added, pre-emptive thanks for your help.

    I'm not a good person to ask if it works with MultiRoles since I can't get it working at all :P. It probably does work.
  • Well I just updated Mootools because it wasn't properly targeting the other JS scripts in the head. Now it should place the framework underneath ac.js. Go download the new version and tell me if it makes any difference.
  • I've installed Mootools 1.4, disabled it and UserInfo and reinitialized them both (with Mootools first). Doesn't seem to have worked.
  • There are some known incompatibilities with Notify. Try disabling it temporarily and see if it removes prototype and scriptaculous from the head as prototype is incompatible with Mootools. I would have expected some javascript errors though which is why I'm dubious as to whether prototype is the problem.
  • Yep, got Notify turned off, and it's still not working. I didn't think it could have been notify either, since I only got that working after UserInfo was already installed. I'm good at causing problems, I'm sorry.
  • Ha, don't worry, it's probably not your fault. I've always hated Javascript for this very reason (and others) - it's so difficult to debug sometimes.
  • Could you put:
    console.log(lns)
    after line 10 of userinfo.js please.

    If it still refuses to log anything then it would seem as though that code is not being run at all. For why, I do not know. It may require a re-write.
  • OK, that's all sorted. This is what I've got now:

    var lns = $$('.CommentHeader ul li a'); console.log(lns) for(var i = 0; i < lns.length; i++) { var ln = lns[i]; if(ln.hasClass('WhisperBack')) continue; console.log(ln) var uname = ln.innerHTML; var tDat = assocDat[uname];
  • Ugh, the code's not being run at all and there are no error messages to speak of which makes it really difficult to debug. I'll re-write the javascript for it tonight and upload it. Hopefully that will give me some idea of what's going on.
This discussion has been closed.