Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Sitemaps: Not sure if it works

This discussion is related to the Sitemaps addon.


  • Doesn't work for me either. How is this an approved plugin?
  • Ieek, isn't this an approved plugin from t? Doesn't seem to work for a lot of people. Maybe it would be helpful to set its state back to "unaproved" so that people are warned.
    Was just about to say..

    whats the status of this plugin? should i try it out? i tried it int eh past and it didnt (seem to) work - but its still "approved"
  • Doesn't work for me either. How is this an approved plugin?
    Totally agree... Not working for me either (vanilla!
  • RajioRajio
    edited July 2011
    I'm still getting a sitemap linking too an xml file containing nothing but

    <Exception> <SCRIPT/> Code404/Code <Message>Page not found.</Message> </Exception>

    any progress on the update @Tim?

  • 404
    Page not found.

    Not working in beta version

  • xsilentxsilent New
    edited August 2011
    it works on me.. I show you how to do this.

    1. go to
    2. go to your home/patch/to/vanilla/cache/Sitemaps/ to check is the file xml available on there. (remember the name of it, example: sitemap.76ef4bd7cef746bd79c071e5d77cd6e91b68e6ec.xml)
    3. go to dashboard -> routes
    4. add route
    5. at the field of routes expresion,just write sitemap
    6. at the target field, just type your xml in the cache/Sitemaps/ folder, its like cache/Sitemaps/sitemap.76ef4bd7cef746bd79c071e5d77cd6e91b68e6ec.xml
    7. choose the type internal then save
    8. then you just type
    9. now you see how it works.

    you have to change the name file on the routes when you update your xml. cause it couldnt be auto update.

    just type when the time you want to update your xml.

    My vanilla version is
    if you dont believe it works on me, you can check my sitemap in

    Hope this will help you and give you the vision.
  • edited September 2011
    Hi all,

    I think I found a solution to this. Having a working sitemap is pretty fundamental.

    So I struggled a bit with this one and after some experiments and finally figured out what the issues might be.

    1. I checked for case matching, Sitemaps might be different to sitemaps. I extracted the .zip file into my plugins folder and it was uppercase. Same when you apply the rules. check its cache/Sitemaps/sitemap.$1.xml with capital S.

    2. Navigating to the urls http://pathtovanilla/sitemap.index.xml rasied 404 error. I checked the cache folder and nothing!? I could also not build new sitemap for I got 404 error. Now I applied Shaman's fix and still got no 404 error but got something in the cache folder.

    3. Having right routes made me think. This must work but why do I still get a 404 error. Only one culprit to blame comes to mind here so to test my theory I tried http://pathtovanilla/index.php?p=/sitemap.index.xml and lo and behold it worked! mod-rewrite!! Hate it! Looking in my root folder I found a neat .htaccess file with all the rules in there already! All I had to do to give me nice url's was to add "AllowOverride All" to my site config file and Bobs your uncle it all worked!

    I hope this helped.

    BTW my vanilla was and looking back I think with rewrite enabled you would not need Shaman's patch.
  • aeryaery Gtricks Forum in 2.2 :) ✭✭✭

    Just go to **** after enabling this addon. Then it should work.

    One fundamental question - The priority of old posts is set to 0.4 which is pretty low though priority of recent posts is 0.8.

    Isnt this be a problem? Will Google stop showing my old posts as results? How to manually change it?

    Vanilla is sweet & support is great, to encourage volunteers, please donate.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator


    I've just installed the plugin, enabled it, checked the config file to confirm it is enabled, done what you said re: build, and got the same as others report: Page not found.

    Strange that it is working for some but not others.

  • @whu606 it doesnt work for me either i have the latest version. i wonder what i've done wrong since this is a fresh installation i have.

Sign In or Register to comment.