Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

I can't install Vanilla Forum

edited September 2010 in Vanilla 2.0 - 2.8
Hi all,

I want to give Vanilla a try but all I keep getting in the installer is:
The connection parameters you specified failed to open a connection to the database. The database reported the following error: SQLSTATE[HY000] [2002] Invalid argument
I have installed many scripts lately without any problem, includding Pligg, 4images, Dolphin 7...

Details as follow: Vanilla 2, Ubuntu 10.04, Apache 2.2.14, MySQL 5.0.5, PHP 5.3.1, Firefox 3.6.8.

Any ideas? Thanks in advance.


  • Options
    RaizeRaize vancouver ✭✭
    first you should check the username and password for the database you are trying to install Vanilla to
  • Options
    Yes, I already tried that. I even created and deleted various users just to be sure. But since you never know, I'll follow your advice and try a few times more. Thanks for your time.
  • Options
    Well, nothing. I tried different databases and different users (with different passwords) giving them global and/or specific privileges.

    Any other idea? Thanks.
  • Options
    LincLinc Detroit Admin
    Is PDO enabled on the server?
  • Options
    Is PDO enabled on the server?
    Yes, it's enabled (pdo_mysql).
  • Options
    Well, I'm going with BBPress then. I had no problems installing the latest version in less than a minute (just like with dozens of scripts before).

    Thanks for your time and good luck.
  • Options
    edited September 2010
    Same problem with OVH.

    Solved now : I had to specify the mysql server name, like "mysql4-99".

    Best regards.
  • Options
    I solved this problem by changing the default 'localhost' to '' for the mysql server name, on the installer page.
  • Options
    Same(?) problem here with Ubuntu Server 10.04 (and all the prerequisites). Does not work using the hostname of the machine or as the database server. Can access the database using the mysql client and the same credentials. Keeps giving me :

    Are you sure you've entered the correct database host name? Maybe you mistyped it? The database reported: SQLSTATE[HY000] [2005] Unknown MySQL server host '~~Invalid~~' (1)
    You must specify the name of the database in which you want to set up Vanilla.
  • Options
    Just a heads up, I got it to work. In my case, the issue was that my pdo_mysql was running, but it wasn't seeing my default mysql.sock location.

    To fix this in my php.ini file, I found the line that said:
    pdo_mysql.default_socket =

    Which was supposed to see the default location, but didn't seem to be working. I changed it to where I put my mysql.sock (varies depending on server, most are in tmp):
    pdo_mysql.default_socket = /var/mysql/mysql.sock

    As soon as I did that, worked like a charm.
  • Options
    edited June 2011

    I have the same error, and i try localhost, and with the hostname, but the installation processus don't work...

    Any idea?

    Edit: Htaccess file was missing but I checked do not use, in addition, the installation finished :)

  • Options
    Yes, I have the same problem, and I note many others have had it too. Some 'answers' have related to the installation of PDO and PDO_MYSQL, but I don't know what they are and I don't have the ability to upload software to my ISP's server.

    I have been a Vanilla 1 user for many years, so I want to persevere with it, but I don't know what I can do. If so many have the same problem, doesn't this mean it is a fault in Vanilla that can be corrected? Or am I being naive?

  • Options
    This subject seems to keep coming up, with many different answers given, most of them beyond my understanding or ability to implement. Is there any official easy answer? Better still, are there any modifications proposed to Vanilla to get around this problem?

    Should I use my old Vanilla version 1, which I know works for me?
  • Options
    LincLinc Detroit Admin
    bump for unsink.
  • Options
    Just for the record, I'm happy to say I have managed to install Vanilla 2 and don't need any help. Must have been a web host problem, or my own mistakes. You can let this sink again if you like. : )
Sign In or Register to comment.