HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

File Upload always shows Uploading.... and never finished

This discussion is related to the fileupload addon.
24

Comments

  • Yes i know, however if i 777 and it still doesnt work, then we've alrdy ruled out another solution.
  • If I put anything other than 777, my forums don't work.
  • TimTim Operations Vanilla Staff
    permissions is 1 thing, but you could try changing ownership to the webserver user instead, and then settings 705 or 755

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • No luck =/ I dug further into where it was erroring out, and it errors out in the jquery.js library file when it goes to the else statement.

    // Open the socket
    // Passing null username, generates a login popup on Opera (#2865)
    if ( s.username ) {
    xhr.open(type, s.url, s.async, s.username, s.password);
    } else {
    xhr.open(type, s.url, s.async);
    }
  • I am also experiencing the same thing as @BradA1878 and @CrazyCarlx2. I have also tried changing permissions as well with no luck. Would certainly be interested in helping find a solution!
  • Also having this very same issue with latest Vanilla / Fileupload addon ... Always shows uploading and never actually uploads anything!
    Folder/File permissions - checked.
    Tested in Firefox only at this point.
  • Dunno if this might trigger some thought processing.. but whenever I hover over the 's.url' part of the code in firebug, the value is set to nothing. it just shows two double quotes. So basically the open() function is sending a url value of nothing.
  • Eeek no resolution on this. Is there a previous version of FileUpload compatible with latest version of Vanilla?
  • try uncommenting your footer.. ZzZzZz
  • edited October 2010
    Had the same problem.

    Found out that it is caused by the browser returning "<pre>{JSON response}</pre>" instead of "{JSON response}" as the iframe document body's innerHTML which is then deemed "Invalid JSON" by the JQuery JSON parser - and so even the initial checkupload test doesn't work. Solution was as simple as

    Response = Response.replace(/^\<pre\>/gi, '').replace(/\<\/pre\>$/gi, '');

    in the FileUpload javascript file in the UploadComplete function body just before it gets parsed by JQuery. That works at least in Firefox. In Opera it only got me one step further, where the upload itself should be finished - Opera error console says something like "Error: inline script compilation" and it appears that it cannot cope with the JSON data sent back from the server. This one will be harder to track because it does not show any trace.

    Vanilla rocks! Peace to you all and thanks for this plug, Tim!

    Dan
  • I found out that there was a file missing in my webspace. Don't know why it wasn't there, maybe it wasn't ignored by the ftp-client cause it has no content.

    I manually created the blank file 'plugins/FileUpload/views/blank.php' and after that it worked.

    greetz

    broodaw
  • Same problem for me
    The path is wrong :

    C:\fakepath\picture.JPG
  • phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    Same for me... Calling the settings, gets me a page rendering without any CSS.
    *argl* getting a little sick of all these bugs, but i shouldn't because i'ven't paid for the work. :)
    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • I also have the issue "FileUp always shows Uploading.... and never finished" when using the Chrome browser, in IE7 it works fine. I don't have access to any other browsers at work so can't test any others.

    Let me know if you need any further details.

    Cheers

  • @Doudou: It'd appear to me that you use Opera, don't you? :o) this is just a security precaution of Opera (and maybe some other browsers, too) against malicious scripts attempting to read a file's real path on the user's computer. It definitely isn't a cause of any bug related to this plugin from my understanding of how it works, just a display issue of sorts.
  • I have the same problem. When i try to upload file, i see progress bar and nothing else.
    Browsers: Mozilla Firefox, Opera, Chrome.
    Rights to /forum 777.
    When i try to debug as advised @cdavid, my FireBug console is empty.


  • TimTim Operations Vanilla Staff
    What version of FileUpload?
    Version of Vanilla?
    Rewrite URLs on?
    Server software and version?
    APC installed?

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • @Tim
    FileUpload - 1.4.0
    Vanilla - 2.0.11
    Mod Rewrite ON
    Server soft:
    1. Ubuntu Ubuntu 4.4.3, php 5.3, apache 2.2
    2. Debian 4.3.5, php 5.3, apache+nginx
    APC not installed
  • MupetzMupetz New
    edited November 2010
    Same here. fileupload never finishes, displaying a C:fakepath/
    FileUpload 1.4.0
    Vanilla 2.0.14
    Rewrite On
    CentOS Shared hosting trought godaddy
    APC no! (dooh...)
  • By the way, just a quick note for Debian 6.0 (Squeeze) servers:

    To install APC, do this:

    apt-get install php-apc
    apache2ctl restart

    APC is ON but progress bar is disabled because rfc1867 is disabled.
    To enable it, do this:

    edit /etc/php5/apache2/php.ini and add:

    apc.rfc1867 = 1
Sign In or Register to comment.