Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

File Upload always shows Uploading.... and never finished

This discussion is related to the fileupload addon.


  • Domos123Domos123 New
    edited January 2012

    ghita3001 said:

    Yes you help. This is the solution that fixed the error for me. Thanks.

    evolucja said:
    I successfully solved this issue. The problem is that it does work only with default theme. If you're using public_vforg theme you have to make sure that your footer part in default.master.tpl looks like:
    <div id="Foot"> <div><span>By Vanilla</span></div> {asset name="Foot"} </div>
    There must be tag inside. After some experiments with footer part all plugin that I had problems with started working.

    Hope it'll help you too.

    Is this the same for php themes?

  • edited January 2012

    If "we" have to alter and change to code, why is this approved? I'm not a developer, I'm someone who needs a simple forum and addons that work. Please un-approve !!

    I changed the "foot" and no upload. Man this really sucks!!!

  • moensmoens New
    edited February 2012

    It appears that this extension is written against the core lib, "class.upload.php" from the git repo here: (>= commit 568b14e262)

    so... heh, what I did was copied that file from git into my 2.0.16... ;P

    ...yeah, not the best idea in the world. lol... but it worked. That file has the Parse() and the Urls() methods and a couple other necessary goodies.

    Bottom line is that the FileUpload addon as of 1.4.4 I think requires 2.0.17 or greater!

  • Hey,
    I'm having the same problem, I just get the upload bar and that's it as well, it never goes further than that, it was working in a more standard theme but now I am using the "Joie" theme and now its not working for some reason. I have tried the latest version and the 1.4.4 version as well and get the same results.

    I'm not all that up on my coding so if there is a fix I need it in pretty simple terms.

    Thanks in advance

Sign In or Register to comment.