Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Why doesn't it work?

edited January 2006 in Vanilla 1.0 Help
I'm a little bit confused (understatement.)

In looking into writing an extension which will allow users to enter the URL of an mp3 to make use of my copy of wimpy button, nothing happens.

So i have been trying a few other extensions which add something to Vanilla, and none of them do anything either.

Here's an example:

Page Manager Extension:
Extension installs and activates fine
Create a new page (a simple link to another location)
No page appears.
Nothing happens.

I've had troubles with the avatar uploader, Clipboard, and most of the other extensions which are meant to add functions to Vanilla. The trouble being that they seemt o function on the back end, but nothing changes on the front end.

Extensions that do work:
Preview Button Extension, Panel Hider Extension, Category Jumper Extension, Quick Keys Extension.

I don't get it... Is the functionality related to the template I'm using? Permissions? Has anyone else had this happen?


  • Are you on 0.9.2 or 0.9.3? Cause a half the extensions dont work with 0.9.3 yet...
  • 0.9.2 and the Soul-Scape theme (only modified css [fonts] and images[header/bg])
  • Have you tried disabling other extensions to see if there is a conflict? Is this on a live server or localhost (home testing).
  • lechlech Chicagoland
    html formatter could be filtering items if you're attempting to post things like flash/gnarly html.
  • NickENickE New
    edited December 2005
    Yeah, that page manager extension dosn't quite work with 0.9.3 yet. I'm waiting until mark adds some delegates to the role form before I convert it though.
  • In order to get an established extension to function, and try to sus out this probelm, I diabled all extensions apart from Page Management, and it's the same story... nothing. Weird.
  • Note sirnots comment...
  • NickENickE New
    edited December 2005
    Well if you're really desperate to use that page manager extension, then here's a sort of beta release of it for 0.9.3: It's ability to hook into the role management form dosn't yet work, but other than that it should function pretty normally, just make sure that the folder CustomPages.php'll be in both exists and is writable (by default extensions/PageMng/, but yet again, easily changable). When those delegates are added I'll finish it off and go through and clean the code up.
  • edited December 2005
    Right, but i'm using 0.9.2. is the latest release of page manager not compatible with 0.9.2?
  • Oh. It should work, you've got the misc/PageMng.php.txt one? Do you have read/write permissions on folder where the CustomPages file'll be?
  • *Light* As is also true with the avatar uploader, the files created by the extension are not associated with my server, or me. owner: 99 group:99 permission: 533 Vanilla, on a linux server running apache, can't manipulate the file, or make use of it. I can't adjust the permissions myself, as the permissions have been set to 533 and the file is not assigned to me (bad file type is the error when attempting to correct, or even delete the file) Is this a windows server vs apache server issue?
  • * Dark * That may not actually be all of it. I removed the file through the server's file manages, and recreated a blank 'CustomPages.php' and loaded it. Gave it '777' to see the results. The extension prints the correct array in this file, but still nothing happens in the menu. For the purposes of determining why this (and other extensions) don't seem to work right, currently the main Vanilla sub dir has 777, as does the extensions folder, and the extension files. weird. What am I missing?
  • NickENickE New
    edited December 2005
    It won't work if you create the CustomPages.php file yourself, as it takes the return value of include()ing it for the tab arrray. It then checks if count() returns 0 and, if so, creates the CustomPages files. Normally, if that file dosn't exist, the extension will automatically take the number to be zero, and recreates the file. However, if it does exist, but does not contain any info which is returned, then include() will return 1 indicating the file was included properly. count() therefore returns a non-zero value and the extension thinks the pages have already been saved. Forget all that, fixed it so you can use a blank custom pages file.
  • MarkMark Vanilla Staff
    If you're concerned about the soulscape theme causing the problems, temporarily switch to the vanilla theme and make sure that this is not the case. You could also try going through the extensions and doing some simple echo statements to make sure they are actually being included.
  • I have done this, and the results are the same, no page is added. is it by chance using fsockopen to function for some reason?
  • I also have to confess some confusion with this extension. First off, The CustomPages.php is successfully created, it is loaded (i've echo'd information out to confirm this, it recalls the names of added custom pages). Also if i actually go to the custom page (manually by typing index.php?Page=MyPage) it correctly loads the page. No matter what, the tab does not show up. The page is really there, but the tab isn't being added. I wonder if this is the same problem a couple of other people are having. I don't think there is any thing special about my setup (i've tried the 0.9.2 version and the PageMng2.0 for 0.9.3 on the appropriate install of vanilla and both behave the same). So, i don't know quite what to do about this. Right now I manually add the tabs and use the PageMng for the creation of pages and editing of their contents, but this is clunky and shouldn't work this way.
  • NickENickE New
    edited January 2006
    I really don't get how this could be happening. Just now I've downloaded the extension version 1.5, the latest 0.9.2 vanilla release, and it worked a charm. My only thought it that it, somehow, might have something to do with permissions, or is being messed up by another third-party extension.
  • I had problems with this extension too. And I had no luck debugging it. I'm just going to wait for 0.9.3. Don't really need it anyway.
  • NickENickE New
    edited January 2006
    Well, from the sound of it, it seems as if it manages to save the pages, and display any custom ones, but dosn't manage to set and/or implement the head rendering hook. Do you guys happen to have any third-party extensions enabled that mess with rendering or the menu in any way? It really is limiting as I cannot, for the life of me, seem to replicate this problem.
  • I'm having the same problem. I don't think that any extensions are causing it? This could be a very useful extension.... Thanks
This discussion has been closed.