Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Error when deleting conversations

I'm getting an error when I try to delete a conversation:

Fatal error: require_once() [function.require]: Failed opening required '/home1/me/public_html/forum/applications/controllers/class.controller.php' (include_path='.:/usr/lib64/php:/usr/lib/php') in /home1/me/public_html/forum/library/core/class.dispatcher.php on line 539

I noticed that it's missing the "conversations" part, and the url is wrong (http://server/me/forum/me/forum/messages/all -- I can't give out the site right now because it's still in development). What can I do to fix this?
«1

Comments

  • I found out that this is also happening with discussions.
  • TimTim Operations Vanilla Staff
    have you tried deleting your cache/*.ini ?

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Thanks for the response Tim. That didn't seem to work. :\ I'm still getting the error.
  • TimTim Operations Vanilla Staff
    What version of Vanilla are you using at the moment? I know you're a relatively early adopter, so I have a suspicion you're still on a slightly older branch perhaps?

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Sorry, I should have mentioned that. I have 2.0.11.
  • TimTim Operations Vanilla Staff
    That's very odd. Let me check something.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • TimTim Operations Vanilla Staff
    Im afraid I can't reproduce this. Have you made any changes to the code?

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • We had to apply a small fix to /forum/applications/conversations/model/class.conversationmodel.php to make email notifications work, because we were having issues with that too. But I commented that code out and the error was still there. I also tried disabling all plugins to see if they were interfering, but that didn't help.
  • TimTim Operations Vanilla Staff
    Maybe @Mark or @Todd has an idea

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Thanks for your help Tim, I appreciate it.
  • TimTim Operations Vanilla Staff
    I'm trying to get a couple of things done today, but I'll come back to this!

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • @ellieroepken, do you mind posting the fix for email notifications? I think everybody is having the same problems. Would be great to get a fix for that.
  • edited October 2010
    @dan39 Sure. I didn't write it, but I know it works for us. I don't know if it will work for everyone. Let me know if it works for you. Apply the following fix to line 167 of /forum/applications/conversations/model/class.conversationmodel.php, AFTER the ending foreach bracket but BEFORE the $this->SQL line:

    $Fields['ConversationID'] = $ConversationID;
    $Fields['Body'] = $FormPostValues['Body'];

    // Grab the users that need to be notified.
    $UnreadData = $this->SQL
    ->Select('uc.UserID')
    ->From('UserConversation uc')
    ->Where('uc.ConversationID', $ConversationID) // hopefully coax this index.
    ->Where('uc.LastMessageID', $MessageID)
    ->Where('uc.UserID <>', $Session->UserID)
    ->Get();

    $ActivityModel = new ActivityModel();

    foreach ($UnreadData->Result() as $User) {
    $Story = ArrayValue('Body', $Fields, '');
    // Notify the users of the new message.
    $ActivityID = $ActivityModel->Add(
    $Session->UserID,
    'ConversationMessage',
    $Story,
    $User->UserID,
    '',
    "/messages/$ConversationID#$MessageID",
    FALSE
    );
    }
  • edited November 2010
    Has anyone found a solution for or been able to replicate this? Should I just suggest attempting to upgrade?
  • The error shows up on other things now. :\
  • And no one can log into the forum, I can't either. The whole forum is broken.
  • TimTim Operations Vanilla Staff
    Sounds like nukes have hit your server. If you like, I'll take a direct look at your setup if you'll give me the relevant login details in a PM.

    (server SSH and Vanilla admin would be great).

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • edited November 2010
    Okay... uploading 2.0.13 didn't work. I'm still getting the error.
  • The forum is back up and I'm able to access it, but I'm still seeing the error when deleting conversations.
  • edited November 2010
    I'm sorry to bother you guys, but I still need help with this.
Sign In or Register to comment.