Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Can't add new themes without Bonk message appearing

edited October 2010 in Vanilla 2.0 - 2.8
I've successfully installed Vanilla 2 but cannot change to another theme (several installed and even the pre-installed Embed theme won't function).

Is this a permissions issue? (No instructions are available in the documentation...)
Or something else?



  • Don't think a permission issue as Default and Embed themes have the same permissions....
  • I think there's a way to disable the bonk, it isn't very helpful.
  • Tried that - and it caused even the default theme to have the bonk error - and with no further detail revealed in the error message...
  • On a non-production machine, try changing this in conf/config.php:
    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';
    and then let us know what you get.

  • As mentioned I tried that....

    This time online I get the error message:

    Fatal Error in PHP.trigger_error();

    Smarty error: the $compile_dir '/home/*****/public_html/vanillaforums-Garden-8225188/cache/Smarty/compile' does not exist, or is not a directory.

    The error occurred on or near: /home/*****/public_html/vanillaforums-Garden-8225188/library/vendors/Smarty-2.6.25/libs/Smarty.class.php

    (where * is my change for anonymity)

    However, I've made no change to the file structure or seen any instructions to make a file 'compile'...

    Has some php instruction not taken place or do I need to just make a file or folder?

    Thanks, Tim
  • Not sure but had a similar problem. Maybe this will help.
  • I cannot create a folder in that directory - there must be something else wrong!
  • TimTim Operations Vanilla Staff
    Delete all the *.ini files in your cache/ folder.

    Vanilla Forums COO [GitHub, Twitter,]

  • Yes, but what is that intended to achieve?
  • I just get the same error, and I cannot create a folder inside Smarty
  • TimTim Operations Vanilla Staff
    What are the permissions on your cache/ folder?

    The cache/ folder is intended to be a place where the webserver is allowed to write temporary files. The reason you yourself cannot modify the cache/Smarty/ folder is because the webserver created the folder. You'll not have permission.

    The reason I suggested deleting your cache/ folder's .ini files is because it looks like the temporary unzip folder name "vanillaforums-Garden-8225188" is still being used in paths. I found it hard to believe that you are still using that in a URL, hence my assumption that your cache entries were out of date.

    So, is "vanillaforums-Garden-8225188" in your URLs?

    Vanilla Forums COO [GitHub, Twitter,]

  • Thanks but you're not being entirely clear.

    You do not explain - "I found it hard to believe that you are still using that in a URL" - it's not a question of belief. I just have done a standard install of Vanilla, the Embed plugin, and a few themes. The install seemed to go ahead fine and I have no reason to assume anything was wrong until I tired changing the theme.

    Only the default theme works, and it does (when I place back that line in the config file, if ugly blue), and the error with that line removed is as described.

    I managed to add a file to the Cache but not Smarty - it was the Dan above that suggested this (and I said it didn't seem logical).

    I may need to change the permissions back for the cache file after several attempts but you don't explain yourself (and the Documentation is AWOL).

    The base URL of the forum is /vanillaforums-Garden-8225188/ and I have no reason to think this is not the appropriate URL.

    Please explain yourself.

  • Permission of cache folder is 774 - I've tried various combinations so changed it a few times (only after theming has failed and prompted by Dan above).
  • Just out of interest do you have Xcache or another PHP accelerator installed? Try clearing / disabling it. I had a problem with Xcache.
  • TimTim Operations Vanilla Staff
    As a temporary exploratory fix, give "chmod 777" a try and see if that improves things.

    Vanilla Forums COO [GitHub, Twitter,]

  • No difference, still the only theme that doesn't show bonk is the default theme.
    ... and eact same error message when line 31 removed from the config file when another theme is applied....
  • TimTim Operations Vanilla Staff
    If you like, PM me your forum information and I'll see if I can get to the bottom of it directly.

    Vanilla Forums COO [GitHub, Twitter,]

  • I'm having the same issue here. Has anyone been able to find a solution? Seems like a pretty major bug if you can't change the theme without it giving errors.
  • LincLinc Detroit Admin
    @fourmind Is the permission on your /cache folder set to 777? Have you edited your conf (above) to see the actual error?
  • @Lincoln Thanks for that info. Turns out it was a separate error with some customization I was doing. My bad.

    For others who find this, however, you can secure those directories, cache, conf & uploads with proper permissions of 755, as long as they're owned by the apache user, which they will be if PHP creates them. You can write a script so that PHP will create those directories for you, provided the root is set to 777. Once you've run your script, you can change the root back to 755.
Sign In or Register to comment.