Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Basic Problems with Vanilla 2.0.11 and ProxyConnect 1.8.3

edited October 2010 in Vanilla 2.0 - 2.8
I basicly installed many times a new Vanilla 2.0.11 Version and ProxyConnect 1.8.3. I want to make it work with ModX CMS. So I also installed a basic ModX Version. The forum is installed on and the CMS on

I completly do what you write in all your documentation. I also think I understand everything. My CMS gives me a correct Authenticate URL if i am logged in:

UniqueID=1 Name=siteadmin
If I am logged out, its correctly empty. Now I log in on and after this I load, it is not logged in. if I click "Sign In" it correctly links to my cms login page.

It seems that Vanilla or the ProxyConnect still not get notice that I am logged in. Or maybe the path is not accessable or empty from Is there any debugging chance behind-the-scene? Do somebody else have that problem or can help me? Test installation would be accessable on demand. I really getting crazy about this. :(


  • Options
    One more thing i founded out, if i click the Sign In Button on Vanilla while I am logged in in the CMS and the AuthURL content is filled correctly, Firebug gives me following return:

    Loading failed::
    Maybe somebody understand this under the posted problem?
  • Options
    I'm having the EXACT same issues ... only with cakephp.

    My developer knowledge is sparse at best, for what it's worth, so it could be something I'm doing wrong.
  • Options
    Same problem here
    It seems that the proxyconnect has problems getting the data from the authentication url(it reads it well, it gets the username and all that) but somewhere beyond that it loses all data and does what he wants...
  • Options
    edited October 2010
    Did your check the source code of the authenticaion url? I found maybe wrong code examples with 2 breaks (\n\n), so there was a free line between UniqueID, Name and Email row. But anyway i did not get it working.

    Did your also check the CURL extension on your webserver, this seems to be a requirement of Proxyconnect. You have to enable it. By default it is maybe disabled. Check it with phpinfo().
  • Options
    edited October 2010
    Hi, I have tried a plain text url connector and also didn't worked, so I think that the problem it isn't the cookie. And in my case the CURL it's enabled
    (cURL support enabled
    cURL Information libcurl/7.19.2 OpenSSL/0.9.7e zlib/1.2.3 )
    The code of the authenticacion url should be OK, I have tried lots of options and didn't worked any of them. Now I am trying with the same text(gotten from the sourcecode) of the example and still nothing.
  • Options
    Any idea if there is somebody working with this problem or the author is aware of this?
  • Options
    TimTim Operations Vanilla Staff
    I am aware of you guys having issues, but haven't got time to look at ProxyConnect for a little while. If you want me to look at your install, send me a PM with your server details and login info and I'll check it out.

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    One of the members gave me the hint that my post

    could stand in relation with this thread. Is it so?
  • Options
    Hi Tim (and everyone else), I think I'm having the same problem.

    I'm using CodeIgniter PHP and figured out the required custom code/cookies to have a page called /vanillaProxyConnect that produces the correct plaintext variables (with the correct linebreaks).

    Nothing seems to happen though.

    Does anyone know how to solve this?

    I've spent hours and hours and need to get this figured out right away.

  • Options
    I'm having the same problem. See my post

    (The following is preliminary. It's now 12:40am....I'll check my work and do more on this in the am.)

    I believe the problem is that the response from the SSO supplier (your website) is not being correctly parsed by the plugin.

    The plugin is receiving
    Name=Larry K

    Instead of
    Name=Larry K

    function ProxyRequest in file vanilla/library/core/functions.general.php

    I think the function is not parsing the html response from the server correctly. It's chopping off the first 4 characters.

    The function has two modes: one where the php curl lib is installed, one where it is not. My guess is that the problem occurs in only one of the modes.

    Stay tuned, more in the morning.


  • Options
    I found the bug. It's in core Vanilla. Turns out, doesn't matter if you have curl library installed or not. Only matters how your SSO response is formatted.

    If it was something like

    Name=Larry K

    it would work fine.

    Or any response where the first 4 characters were not needed.

    Patch posted, see
  • Options
    LincLinc Detroit Admin
    This is now patched on unstable branch for the next release.
  • Options
    edited April 2011
    I'm currently running today's unstable branch. The problem still persists, at least for me.

    Edit: sorry, I meant to post this in a different thread (
  • Options
    edited June 2011
    Hi all, I'm not sure how much this is related to the thread discussion but I would still like to share some of my knowledge on the SSO integration as I have managed to completely integrate proxyconnect with the sso plugin.

    One of the problems I faced initially was the use of cookies by vanilla whereas I was using session in my website. I realized that coookies were being created whether or not you are logged on whenever you go to the vanilla forums.
    Here's a description of the error I encountered.

    Scenario A
    I am not logged in. I click on the vanilla forums as a public user, then clicked on sign in via sso, and headed back to the vanilla forums. I find myself not logged in to the forums.

    Scenario B
    I am not logged in. I click on the vanilla forums as a public user, cleared my cookies via "clear history" in FF, then clicked on sign in via sso, and headed back to the vanilla forums. I find myself logged in to the forums.

    Scenario C
    I am not logged in. I head straight to the sso page, and proceeded to the vanilla forums. I now find myself logged in to the forums correctly.

    I am not entirely sure why it behaves this way as I have not dug deep enough to look at the core codes at the moment, what I did to fix this was to remove the cookie created whenever the user is signing in.
Sign In or Register to comment.