Please upgrade here. These earlier versions are no longer being updated and have security issues.

Vanilla 2.0.13 Released

This discussion is related to the Vanilla addon.
2»

Comments

  • is there a way to turn off the theme-switching for mobiles?
    my custom theme is already mobile friendly (css solution), and i don't want to use the mobile theme, thanks
  • SS ✭✭
    edited October 2010
    Who has problem with disappearing items/links in dashboard @ sidemenu by custom apps/plugins
    Add
    $Configuration['Garden']['DashboardMenu']['Sort'] = False;
    to conf/config.php
  • RaizeRaize vancouver ✭✭
    Heads up...

    In the upgrade instructions it says to leave the "conf" folder intact, but the mobile theme will not work if you do that.

    In order for the mobile theme to kick in on mobile phones, you have to over write the old "config-defaults.php" file with the new one in the 2.0.13 package.

    It's awesome I'm loving it!
  • TimTim Operations Vanilla Staff
    is there a way to turn off the theme-switching for mobiles?
    my custom theme is already mobile friendly (css solution), and i don't want to use the mobile theme, thanks
    $Configuration['Garden']['MobileTheme'] = FALSE;

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • LincLinc Director of Development Detroit Vanilla Staff
    @S I experienced this problem as well; it is now patched in unstable branch.
  • Hi! Help? :) I'm trying to upgrade from 2.0.11. Because I'm using ProxyConnect, I also copied over ProxyConnect to the plugins folder before trying to /utility/structure.

    I can log into the admin fine, the utility updates, but… the main page of the forum just says "Bonk!".

    How can I figure out what's wrong?
  • TimTim Operations Vanilla Staff
    From the original post in this thread:

    Troubleshooting the Vanilla 2 Installation

    If you run into any issues during the installation, you may see the "Bonk" error screen. In order to get past this screen, you can remove the following line from your conf/config.php file:
    $Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';

    This will show you a more detailed screen of information about the actual problem you've encountered. Please include this information when reporting issues (copy & paste exact errors, please).

    Vanilla Forums COO [GitHub, Twitter, About.me]


  • 3. Fixed bug with deleted discussions where the page would not redirect after deletion
    This problem still exists when deleting private messages.
  • edited November 2010
    :)
  • This is great. Exactly what I've been wanting for my forum, for which we're only testing things out at the moment (http://www.bangthebore.org/vanillatest)

    Generally great for smartphones. Smooth and quick, nice layout. Feels as good as posting to the site on my desktop.

    I'll do some more testing tonight, these are my thoughts for now:

    1. Signing in and out. Was hoping that this would be fixed in the upgrade but it's not working, it's giving a 'Page not found' page for every sign-in and sign-out. A two-click workaround for this, just click back then refresh. Still, this will be people's first experience as a forum member and so it might be off-puttingly buggy. I'm wondering whether it's an issue with how we've installed the forum as I can't see that many other people here have had this problem. Thoughts?

    2. I'm no programmer, but a friend drafted a workaround so that the main page just lists the categories. I've just restored that php file after the upgrade... It works fine on the desktop but not on the Blackberry, where the main page is now just blank. But I can click on 'Discussions' to see a list of topics in chronological order for when they were last posted, so it's a one-click workaround. Any ideas how to fix this for good?

    3. Photos & embeds: these work fine on the desk top but are not automatically resized for Blackberry. They distort the shape of the forum on the smartphone browser. I don't like forums with lots of embedded and photographic content but realistically we'll be running a music forum, so people are going to do it. Any ideas?

    4. On certain forums the forum name button has lost its right hand border when you go into an individual topic. A very minor aesthetic thing that I've found with both versions of the forum, both pre and post upgrade.

    Thanks tons for this, though. Vanilla for smartphones was top of my wishlist and it's pretty great so far!
  • LincLinc Director of Development Detroit Vanilla Staff
    edited November 2010
    @sethcooke
    1) Could you describe this bug in greater detail in a new discussion or as an issue on GitHub as requested in the first comment? This isn't a good place to debug.

    2) Probably because he didn't also make the change in the Mobile theme.

    3) Sounds like an issue with the mobile theme. Again, a good topic for a GitHub issue or a separate discussion.

    4) Could you describe what you mean? I'm not aware of any right-hand border on the forum name in the default theme.

    Glad you're enjoying Vanilla. :)
2»
Sign In or Register to comment.