Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

New version of plugin won't appear on plugins list in admin interface

This discussion is related to the Quote selection addon.
tmilovantmilovan New
edited November 2010 in Vanilla 2.0 - 2.8
New version of plugin (0.6.1) won't appear on plugins list. I have vanilla 2.0.13 installed.
Tagged:

Comments

  • LincLinc Director of Development Detroit Vanilla Staff
    edited November 2010
    I've had multiple times where I couldn't get a plugin to show up for various reasons. Did you previously have Quote Selection installed or was this your first use of it?

    Are you sure default.php and the other files are in /plugins/QuoteSelection/ ?

    Also, try deleting the ini files in your cache folder. Probably unrelated but won't hurt anything.
  • 1. Yes, I have an older version.
    2. Absolutely, yes :).
    3. I did that, didn't help :(.
  • edited November 2010
    I can't see the quote plugin either. Could this no show have something to do with having the other quote plugin installed? I wanted to compare them. But since Quote Selection did not show up I deleted the other plugin. Still did not show.
  • What do you mean when you say that it "did not show up"?
  • It probably means that he don't have it on the plugins list in Administration interface.
  • That's weird. Have you tried deleting it from server and uploading again?
  • Yep, every time the same. Recently I have found that most of my problems are because I have migrated forum from phpBB3 and have my group id's are different from default Vanilla installatio. Can that be the cause of problems here?
  • Not sure, but this might be possible. BTW, have you upgraded your Vanilla installation to 2.0.14?
  • Yes. Overwritten the config directory too, cleared cache, etc.
  • Btw. QuoteSelection 0.6 is working ok, it's just newer versions that are causing the problem.
  • My install of Vanilla 2.0.14 is brand new with no imports from external forums, and QuoteSelection 0.6.1 for Vanilla 2 will not show up on my plugin list. I have deleted it and uploaded a fresh copy and is still does not show up.

    One odd thing: I looked at the readme file to find the version number and it says "Quote Selection plugin version 0.6 for Vanilla 2".
  • @virtualdavid Can you please check the permissions of the plugins folder in your Vanilla installation?

    /cd
  • Is 755 not ok?
  • the plugins folder was set to 755. I just changed it to 777 as well as the QuoteSelection folder. But QuoteSelection still does not show up in the Dashboard.
  • Out of ideas -.-

    /cd
  • Try changing permissions for default.php file.
  • Try changing permissions for default.php file.
    That did a trick. Thanks.
  • Fixed it for me too!

    Specifically the file located here: /plugins/QuoteSelection/default.php it's permission was set to 600 and after I changed it to 644 the QuoteSelection plugin showed up in my plugin dashboard. THANKS!
Sign In or Register to comment.