Please upgrade here. These earlier versions are no longer being updated and have security issues.

Vanilla 2.0.14 Released

This discussion is related to the Vanilla addon.
2»

Comments

  • edited November 2010
    I just noticed that when I sign in with my Twitter account the pop up box comes up, I put in my Twitter account info, then click on allow. Then, the pop up box changes to the "redirecting, if you are not redirected click here". Well, I was never redirected. So, I clicked the link, and my forum loaded, but it loaded inside of the pop up box. I closed out the pop up box and refreshed my forum's main page and it worked, I was logged in with my Twitter account. But, again, I was not auto-redirected and when I clicked the link to be redirected, it loaded in the pop up box instead of refreshing the forum page, which is what I think it should do...

    What would cause it to not automatically redirect?

    You can try for yourself at i.ndiesho.ws/community
  • Mobile theme still doesn't work for me : ( ( Android )
  • TimTim Operations Vanilla Staff
    You can try the latest unstable code if you want to get Android working...

    https://github.com/vanillaforums/Garden/zipball/unstable

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • How do I use the "Sign in with ...." button instead of the icon?
  • As mentioned above I am getting duplicate email notifications AND the quoted text in the notification is shown with all the formatting code. Anyone else seeing this?
  • I have an error if i want to enable Google SignIn :(
  • edited November 2010
    As mentioned above I am getting duplicate email notifications AND the quoted text in the notification is shown with all the formatting code. Anyone else seeing this?
    I wish I were...at least then I'd know email notifications were working. ;)

    I, for one, am glad to see official support for a rich text editor...but between cleditor and htmlawed, I was getting invalid code tags, like img and br weren't being closed properly with "/>" - I had to hack both htmlawed (hook tag) and cleditor (xhtml plugin) to get my site to validate again.
  • BTW, unsigned users on this forum see "Vanilla 2.0.13 released" announcement above discussion list.
  • OK so now I've tested it I can only find one fault, the emails sent to the Twitter or Facebook users is "[email protected]" what's that all about?
  • edited November 2010
    Don't yell at me now... I know we're not supposed to be talking about bugs here, we're supposed to do that at GitHub... but, not only are the facebook and twitter connect plugins giving me issues (see my comment up above somewhere) but I just noticed the Emotify plugin isn't working. I can enable it and I see the little smiley face when I'm posting a discussion, but when I click on the face nothing happens and if I input a face like so --> :) .... it doesn't change into an emoticon.

    I may just revert back to the basic Vanilla forum with no facebook/twitter login and no emoticons, etc... the basic Vanilla forum works beautifully but I'm not sure about all these recent add ons.
  • i think i have the same problems here
  • LincLinc Director of Development Detroit Vanilla Staff
    @greenlizard It's fine to discuss issues here and we're not going to yell at you... but we're probably going to forget to deal with the issue when we sit down to code. We ask for issues to be thoroughly reported on GitHub so they are properly responded to, not because we're control freaks about what goes in a discussion. Example: I coded all day Saturday and never thought about this one because it wasn't in GitHub. There's only a couple of us dealing with issues and dozens of you reporting them, so the minimum amount of help we need from you is to help us organize the issues in 1 spot. :)
  • edited November 2010
    @Lincoln you got it man! I'll make sure I post issues at Github. It looks like someone already posted about the emotify issue and I posted about my twitter redirect issue.

    Thanks!
  • LincLinc Director of Development Detroit Vanilla Staff
    edited November 2010
  • edited November 2010
    As far as notification emails not being sent, is anyone else having this specific issue?

    https://github.com/vanillaforums/Garden/issues/issue/630/

    Please test and confirm. I think it's all related. Hopefully we can all get to the bottom of this. Thx.
  • @dan39 I get all e-mail notifications from VanillaForums.org ... Though, I haven't updated to 2.0.14 yet.
  • edited November 2010
    I don't understand why VanillaForums.org is different from some other installations. That puzzles me.

    Other people have seen this issue, but it's never been addressed. Take a look at the following closed issue and look at the comment halfway down from glowprod.

    https://github.com/vanillaforums/Garden/issues/issue/452/

    glowprod describes the exact same problem in Issue #630.

    It's maddening.

    Basically what used to happen before Issue #630 was "fixed" is that no notifications were sent until your return message was answered by the original sender and whereupon two notifications were sent — the two simultaneous notifications were actually different types of notifications: "EmailStoryNotification" and "EmailNotification" were being sent at the same time only after a reply to a reply. In reality, you should have been delivered EmailStoryNotification when the message was first sent and EmailNotification when the second message was sent.

    (FYI, I believe EmailStoryNotification announces the new incoming message and EmailNotification alerts you that a reply was given).

    As of 2.0.14, I (and a few other people apparently) only get EmailNotification for some reason. Can't figure out why that is. Something isn't right with the way EmailStoryNotification is sent out because now I don't receive it. Why VanillaForums.org doesn't have that issue, I have no idea.
  • New user - new install :)

    I followed the instructions, everything is fine but . . . when I went to anything in forum settings, I get a page not found.

    vanilla/settings/managecategories
    /settings/spam
    /vanilla/settings/advanced

    etc.

    Now, this could be because I installed it in the root of the website. My path is not xxx.com/vanilla for the install.

    So this seems to be an undocumented feature in the install :)

    Is there a solution for this?
  • LincLinc Director of Development Detroit Vanilla Staff
    FYI, having /vanilla in the path isn't related to the folder your install is in. Technically you could navigate to discussions on any site via /vanilla/discussion/1234/discussion-title-here, but typically the /vanilla part is omitted.

    Are those the 3 paths you're getting from the dashboard, or are they the combinations you tried? I've never heard of a functioning forum where the settings section randomly didn't work.
2»
Sign In or Register to comment.