Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Install Process Problem

edited November 2010 in Vanilla 2.0 - 2.8
I'm getting a "Error 403 - Forbidden You tried to access a document for which you don't have privileges." I have the vanilla folder in place what do I do ? I use 1and1 hosting does anyone know if they don't have the right requirements?

Update: now I get this error "Parse error: syntax error, unexpected ',', expecting '(' in /homepages/27/d160915290/htdocs/yourfundingus/vanilla/bootstrap.php on line 64"


  • Also, I noticed the "config.php" isn't in the zip folder ?
  • LincLinc Detroit Admin
    Use phpinfo() to see if it supports PHP 5.2. It sounds like it does not.

    config.php is written upon installation; there is no default version of it.
  • Thanks Lincoln I'll give that a try!
  • zavrtakzavrtak New
    edited November 2012

    I have the same problem (403) when I try to install and I am running PHP Version 5.3.15
    The folder itself is even invisible when I try to access it via /localhost/~user/

    Problem seems to related to the .htaccess as I can access the folder without it. Though I have not much ideas how to fix this problem right now.

    I found a closed bug tracker, though the issue should have been resolved years ago. Any ideas?

  • @zavrtak I highly doubt that your problem is the same as you most likely tried to install

    To get on track here: What is your exact configuration of your server? Which folder did you put the files in? What does the .htaccess file look like?

  • zavrtakzavrtak New
    edited November 2012

    Yes, I am using

    <IfModule mod_rewrite.c> RewriteEngine On # Certain hosts may require the following line. # If vanilla is in a subfolder then you need to specify it after the /. # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum) # RewriteBase / RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L] </IfModule>

    I am using a simple ~SomeUser/Sites/vanilla folder which represents localhost/~SomeUser/vanilla in apache and I am using the default osx server settings.

    Same if I place it instead directly into /~SomeUser
    I guess the problem is the RewriteBase and my configuration, I will try to get some more knowledge on htaccess-files and the rewrite engine via google.

  • OK. Found my problem, the RewriteBase was not working right, as I am using another dir for my private user. The rewrite seems not work in that dir, and I am not educated enough to fix this. Installation worked fine in the document root dir .

  • businessdadbusinessdad Stealth contributor MVP

    You could try uncommenting # RewriteBase / and changing it into RewriteBase /vanilla (or whatever directory you used.

  • OK. I was now able to figure out what I was doing wrong.

    My apache config does implement user folders as usual for osx, my simple mistake was not to realize that the user folder in apache was my home directory and not the corresponding Sites folder on directory deeper.

    I had to use the correct RewriteBase, which is in for "http://localhost/~USER/vanilla"
    RewriteBase /Sites/ as the home directory itself is root folder, even when your apache config added

    <Directory "Users/USER/Sites/"> Options Indexes MultiViews FollowSymlinks AllowOverride All Order allow,deny Allow from all </Directory>

    I hope this makes sense for anyone who might run into this problem.

  • businessdadbusinessdad Stealth contributor MVP

    I knew it was that, I had my share of stress and tears over it in the paste. :D

Sign In or Register to comment.