Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Twitter,Facebook,Google Signin Problem

edited November 2010 in Vanilla 2.0 - 2.8
After installing the latest vanilla , and the social features (facebook,twitter,google) and following the steps to set the API key etc, following the install step by step doing the aPI registration thing with said sites, facebook, google and twitter,

When Users click on the icon for twitter, or facebook, or goggle they just get a


Something funky happened. Please bear with us while we iron out the kinks.

Any idea why this would happen? and the twitter returns a

Desktop applications only support the oauth_callback value 'oob' /oauth/request_token Fixed this issue


  • Options
    Try to go to conf/config.php , edit the line about error messages to look like this:
    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php'; -- the default value is error.master.php -- reload / refresh, get the actual error, paste it here and then revert the code back to error.master.php.

  • Options
    okay sorry was at work

    Fatal Error in Smarty.trigger_error();
    Smarty error: the $compile_dir '/home2/ghubnet/public_html/forums/cache/Smarty/compile' does not exist, or is not a directory.
    The error occurred on or near: /home2/ghubnet/public_html/forums/library/vendors/Smarty-2.6.25/libs/Smarty.class.php

    1109: * @param integer $error_type

    1110: */

    1111: function trigger_error($error_msg, $error_type = E_USER_WARNING)

    1112: {

    1113: trigger_error("Smarty error: $error_msg", $error_type);

    1114: }



    1117: /**


    [/home2/ghubnet/public_html/forums/library/vendors/Smarty-2.6.25/libs/Smarty.class.php:1113] PHP::Gdn_ErrorHandler();

  • Options
    Any Ideas?
  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    Create the following folder in your installation: /cache/Smarty/compile.

    You should have the Smarty folder, just not the compile folder.
  • Options
    I added that folder earlier but I guess it would help if my spelling wasn't so blah when I'm tired spelled it "campile" >< Thankz @Todd
  • Options
    edited November 2010
    Hello, I have got the same problem,

    Can you tell me what I have to do ?

  • Options
    LincLinc Detroit Admin
    Did you try Todd's suggestion?
  • Options
    I am gonna try (woowww you're so fast !)
  • Options
    Still doesn't work... I had this file already.

    If you wanna see by yourself:
  • Options
    LincLinc Detroit Admin
    @Snook_ How did you fix the "Desktop applications only support the oauth_callback value 'oob' /oauth/request_token " issue? That's what @Carlo_13 is experiencing.
  • Options
    @Carlo_13 make sure that in your twitter Application that you have the following things.
    Application Type: Browser
    Callback URL: has your url for where the forum
    Callback URL:(correct)
    Callback URL:(incorrect) Entry left blank

    So simply place your url into the Callback URL and that will fix the
    "Desktop applications only support the oauth_callback value 'oob' /oauth/request_token " error your getting
  • Options
    Hi Snook,

    thanks for your answer, I'll try it as soon as I get back home.

    About Facebook:
    When I try to login, and when I have to enter the pass word and choose a username, the field you who know where it comes from ?

    Again, thanks for you help.
  • Options
    Snook, twitter works perfectly ! thank you very much !

    Do you know what I have to do facebook to make it work properly ?
  • Options
    edited November 2010
    @carlo_13 are you logged into and allowed the API application, as I'm able to create Username/password and its not disappearing on me?
  • Options
    edited November 2010

    I know it is weird, everything is fine till (see the cap), when i try to create a username and password, I click on connect, but the pass word doesn't appear.
  • Options
    yes i had a problem.
    but it solved.
  • Options
    How did you solve it ?
  • Options
    I have the same problem, share your solution with us!
  • Options
    edited November 2010
    To fix the facebook plugin, go here:

    Replace your current class.facebook.plugin.php file with that code. They recently updated this file and it fixed my facebook login issues.

    Now if only I can figure out why my twitter login option doesn't auto redirect...
  • Options
    goxonlinegoxonline New
    edited November 2010
    Hi, everybody!
    I have some problems with the Twitter Auth, I get this error:

    Activity type could not be found: Join
    The error occurred on or near: /www/(MiSite).com/htdocs/applications/dashboard/models/class.activitymodel.php
    142: if ($ActivityTypeRow !== FALSE) {
    143: $ActivityTypeID = $ActivityTypeRow->ActivityTypeID;
    144: $Notify = $ActivityTypeRow->Notify == '1';
    145: } else {
    146: trigger_error(ErrorMessage(sprintf('Activity type could not be found: %s', $ActivityType), 'ActivityModel', 'Add'), E_USER_ERROR);
    147: }
    148: if ($ActivityTypeRow->Name == 'ActivityComment' && $Story == '') {
    149: $this->Validation->AddValidationResult('Body', 'You must provide a comment.');
    150: return FALSE;

    This appear after login into twitter and redirect back to the site.

    The aplication in twitter have the correct configuration. After get this error and click again in the twitter icon, vanila show the correct user info, but request the password account.

    Any idea?
Sign In or Register to comment.