HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Authenticators broken in 2.0.14 fresh install?

ddumontddumont ✭✭
edited November 2010 in Vanilla 2.0 - 2.8
I've followed the instructions here: http://vanillaforums.com/blog/help-tutorials/how-to-add-facebook-twitter-google-and-openid-to-your-community

Basically, I'm able to enable the plugins. (openid and google)
But when I go to [Users->Authentication] and try to activate the authenticator, the page flashes and "Current Authenticator" still says "Password"

When I log out to try the connectors, they show up in the login screen.
When I click on the openid or google buttons, they just pop open a new instance of the same login window, not the correct login window for google or openid.


  • ddumontddumont ✭✭
    edited November 2010
    I've set up facebook successfully. It appears that only OpenID and Google auth are having this problem..

    I just set up twitter, it does not appear to work either. Basically twitter, openid, and google auth do not redirect to the appropriate login page when it opens a new window. It still shows a mydomain.com address and my login page.

    Facebook seems to work fine. I get no errors, even when setting the config to use deverror instead.
  • ddumontddumont ✭✭
    edited November 2010
    I reinstalled the forum, and now I got OpenID working but Google Auth is giving me trouble

    No servers found!
    The error occurred on or near: /home/canofsle/public_html/test/plugins/OpenID/class.lightopenid.php
    368: $this->server = $server;
    369: return $server;
    370: }
    372: throw new ErrorException('No servers found!');
    373: }
    374: throw new ErrorException('Endless redirection!');
    375: }

    @Tim any ideas?
  • I'm surprised that you haven't gotten more feedback on this yet. This process seems very error prone :(

    Trying Facebook login. I grant permission and it asks me to pick a unique user name. I provide one, a password field flashes visible and then hides again. I get a red box saying I need to provide a unique user name.... Stuck on this one.

    Twitter seems to log me in after I grant permission. The account is auto created ( I don't get to pick a username ) but the email address for the user profile created is [twitterusername]@foo.com :-/

    Google Auth is failing with the error in the previous post. I have not tried openID.

    How exactly do you have this working on the vanilla site here? Can you share some of the fixes you've run across? Or are you planning an update release soon?

  • TimTim Operations Vanilla Staff
    @Todd should take a look at this. I agree the error messages are a bit... confusing.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • ToddTodd Chief Product Officer Vanilla Staff
    .org is using the exact same code that is available to you so I am a bit surprised you are having so many problems.

    Can you give me an idea of the browser you are using?
    Do you have htaccess enabled?
    Can you paste the exact url into the discussion so I can have a look?
  • I've tried with IE8, Chrome 8 latest beta... There seems to be no difference in the errors.

    I'll pm you the info to try yourself.
  • ToddTodd Chief Product Officer Vanilla Staff
    I think your web server might not have allow_url_fopen enabled in your php.ini. Can you check on this?
  • Ahh! Thank you that fixed almost everything!

    The only issue that remains is that twitter accounts have a [email protected] email address when created. Any ideas?
  • ToddTodd Chief Product Officer Vanilla Staff
    Actually, that is a known issue that I'll have to deal with.
  • Ok. I'll disable twitter sign-in till I hear about an update for the plugin.
  • edited November 2010
    What about this issue: I can log in with Twitter, but after I've authenticated through the pop up box, I don't get auto redirected to the main forum page. In fact, I don't get redirected at all, it just stays on the "redirecting" page. If I exit the pop up box and refresh my forum, I'm logged in. So, I just gotta figure out what is stopping it from redirecting... My forum is embedded and I'm wondering if that has something to do with it.
  • I'm having the exact same error that started this post and I'm dying to know what was the reason for the "Ahh! Thank you that fixed almost everything!"

    What is the fix?
  • "allow_url_fopen enabled in your php.ini"
  • Not sure how to do that. As soon as I find out I'll edit this post unless someone can tell me how before then. Thanks for the lead.
  • Mine was

    suPHP_ConfigPath /path/to/public_html/php.ini

    ; Fopen wrappers ;

    ; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
    allow_url_fopen = On
  • edited November 2010
    @tim moshimo's comment is clearly SPAM - shouldn't the flagging plugin be enabled ?
  • LincLinc Detroit Admin
    @DavyB Got it, thanks.
  • edited November 2010
    "allow_url_fopen enabled in your php.ini"
    My host admin changed this file for me as it does not show in my Cpanel. However after he changed it I still get this error message:

    Fatal Error in LightOpenID.discover();

    No servers found!
    The error occurred on or near: .../vanilla/plugins/OpenID/class.lightopenid.php
    368: $this->server = $server;
    369: return $server;
    370: }
    372: throw new ErrorException('No servers found!');
    373: }
    374: throw new ErrorException('Endless redirection!');
    375: }
    [.../vanilla/plugins/OpenID/class.lightopenid.php:504] LightOpenID->discover();
    [.../vanilla/plugins/OpenID/class.openid.plugin.php:148] LightOpenID->authUrl();
    [.../vanilla/library/core/class.pluginmanager.php:417] OpenIDPlugin->EntryController_OpenID_Create();
    [.../vanilla/library/core/class.dispatcher.php:288] Gdn_PluginManager->CallNewMethod();
    [.../vanilla/index.php:38] Gdn_Dispatcher->Dispatch();
    Need Help?
    If you are a user of this website, you can report this message to a website administrator.
    If you are an administrator of this website, you can get help at the Vanilla Community Forums.
    Additional information for support personnel:
    Application: Vanilla
    Application Version: 2.0.14
    PHP Version: 5.2.14
    Operating System: Linux
    Server Software: Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ PHP/5.2.14
    Referer: .../vanilla/entry/signin?Target=settings%2Fplugins%2Fall
    User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/533.18.1 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5
    Request Uri: /vanilla/entry/openid?url=https%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fid&Target=settings%2Fplugins%2Fall&display=popup
    Controller: LightOpenID
    Method: discover

  • I'm having the same problem, I can not install the OpenID or Facebook plugin. It says "This plugin requires the allow_url_fopen php.ini setting." I contacted the admin of my server and now allow_url_open is on but is still not working. You can check my info here: http://www.guirilandia.com/info.php

Sign In or Register to comment.