Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla stopped working with fatal error require_once() [function.require]: Failed opening required

edited February 2011 in Vanilla 2.0 - 2.8
I installed a pre-packaged WordPress+Vanilla, and it was all working, but then today I get the following:

Fatal error: require_once() [function.require]: Failed opening required 'mydomain/wp/forums/applications/controllers/class.controller.php'
(include_path='.:/usr/local/nf/php5_2/lib/php') in mydomain/wp/forums/library/core/class.dispatcher.php on line 531
of course, there IS no forums/applications/controllers/ folder.
The line of code in question is:

require_once(CombinePaths(array(PATH_APPLICATIONS, $this->_ApplicationFolder, 'controllers', 'class.'.strtolower($this->_ApplicationFolder).'controller.php')));

Any ideas why it is looking in the wrong place?


  • Options
    LincLinc Detroit Admin
    Did you install any new apps or plugins?

    First suggestion: delete the ini files in your /cache folder.
  • Options
    No new apps or plugins. I made a mod to the default.master.tpl file to change the menu and alter the header image, which worked fine for a day.
    Cleared the ini files and it works fine, except now it is using the original template, not my modified version, which doesn't make sense.
    For future reference, is clearing ini files from the cache something I'm likely to have to do often? what causes this error, and how can I prevent it in the future?
  • Options
    The template problem resolved itself - I just refreshed everything.
  • Options
    It crapped out again with a different error, clearing the .ini files again did the job. However, I suspect there is something up with my install, as there seemed to be nothing to precipitate this.
  • Options
    Yes, clearing the cache (by deleting all files in the cache directory) solves this problem.
  • Options
    Hi - had same issue and deleting the cache files fixed it. But I am wondering what caused this in the firstplace as it just seemed to happen without warning or any changes on my part so I am thinking it is only a matter of time before it happens again. Any long-term solutions / absolute fixes? Cheers
  • Options
    lucluc ✭✭
    If you're hosted, it might be because the host changed some parameters in the web server config.
  • Options
    Yes, clearing the cache it solve the problem.
Sign In or Register to comment.