Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

How stable is 0.9.3?

edited January 2006 in Vanilla 1.0 Help
My phpbb forum keeps getting hacked. twice in the last two days, this is the perfect reason, and opportunity, to switch over to vanilla. How stable is the 0.9.3 release? or should i stay well clear?


  • Why don't you just use the current stable release?
  • There are still several bugs, though no real security flaws that I know of. FWIW, I switched my site over to 0.9.3 and everyone likes it.
  • well i just wondered if it was feasible to use the latest release. given that if i'm going to make the switch, it would be my preference to use the most recent version. i was hoping to hold out until the full release but unfortunately i'm being forced into action earlier than i would have liked.

    would it be difficult to upgrade to the full release once it is out what with there being so many changes in the way the forum functions?
  • For the most part, upgrading 0.9.3 revision x1 to revision x5 is no harder than replacing the old files with the new ones. If it's any harder than that, mark usually posts a thread with directions. It's a lot more work than that for me (I'm still on rev 85) because I've made so many modifications.
  • As a pointer, upgrading from (stable) is also extremely easy (and will probably be easier with an upgrade script, i expect) to v1 (on release, ofcourse)
  • MarkMark Vanilla Staff
    As long as you don't touch the core files (and the templates at this point as well), the hardest upgrade should be what you'll have to do right now for 0.9.3. After that it should be as simple as "svn update"
  • MarkMark Vanilla Staff
    How are you getting hacked, by the way? I (sadly) have a lot of experience with this if you needed some help - drop me an email if you like.
  • edited December 2005
    ok im trying to get 0.9.3 going on my pc and i'm getting the following error:

    Fatal error: Class 'Delegation' not found in C:\Program Files\Apache Group\Apache2\htdocs\vanillanew\library\Utility.Class.Control.php on line 16 Fatal error: Class 'Context' not found in C:\Program Files\Apache Group\Apache2\htdocs\vanillanew\appg\init_vanilla.php on line 40

    any ideas?
  • ok i worked around those and now i've got

    Notice: Trying to get property of non-object in C:\Program Files\Apache Group\Apache2\htdocs\vanillanew\library\People.Class.User.php on line 265
  • That seems like an odd place to have a web directory. Maybe there's an incorrect path somewhere?
  • MarkMark Vanilla Staff
    edited December 2005
    How are you getting the repository?

    The best way would require svn. Then go to the folder below where you want vanilla and do this:

    svn checkout vanilla

    If you do that and configure your conf/* files properly, there shouldn't be any errors. For that matter, if you encountered some errors and found a solution to them, please post them so others can learn from your problems. I'm sure there are a lot of people who read these discussions looking for some insight.
  • the first error i got was because i hadn't set up the conf files i.e. copying them and removing the -dist from the filename... doh!

    the error i'm stuck on now though i think is, like bergamot has said, because i've got an incorrect path somewhere.

    i reckon it's the following entry in settings.php which i thought was meant to look something like this:

    $Configuration["APPLICATION_PATH"] = "<Drive>:\<site>\vanilla.093b\\";

    so mine is
    $Configuration["APPLICATION_PATH"] = "C:\Program Files\Apache Group\Apache2\htdocs\vanillanew\\";
  • You shouldn't need double slashes anywhere in your path
  • edited December 2005
    ah that didn't output how i thought it had. this is how i thought the line was supposed to look: $Configuration["APPLICATION_PATH"] = "<Drive:>\<site>\vanilla.093b\\";
  • just to remove any chance of error, forward slashes seem to be the way forward where paths are concerned. Having spaces in doesnt seem like the brightest idea either but that shouldnt cause any problems, i dont think.
  • i didn't think forward slashes would work for a path from c: ? or is that the point, am i not supposed to put the location in from c:?
  • Windows accepts forward slashes in paths, and has for almost a decade.
  • ok i tried the forward slashes and still no luck...
    Notice: Trying to get property of non-object in C:\Program Files\Apache Group\Apache2\htdocs\vanillanew\library\People.Class.User.php on line 265

    i put in the application path as follows:
    $Configuration["APPLICATION_PATH"] = "C:/Program Files/Apache Group/Apache2/htdocs/vanillanew/";
  • MarkMark Vanilla Staff
    Okay, that line references the context object and the configuration array. My best guess is that the context object isn't being instantiated properly. I've gotta ask the obligatory: What version of php are you using? What version of mysql are you using? What operating system/web server are you using? Do you have 0.9.2 installed and working?
  • edited December 2005
    ok im on windows xp pro
    with apache 2.0.54 running
    php 5.0.5
    mysql 4.1.14
    i have 0.9.2 working fine
This discussion has been closed.