Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Members with no username.

edited November 2010 in Vanilla 2.0 - 2.8
I have someone creating an account without a username. How is this possible?

I have a screen shot.

Thank you for the support.


  • Also I've noticed that when I logout I'm still in a account with no username. Here's a screenie

    Thanks again.
  • LincLinc Detroit Admin
    Are you using ProxyConnect or any other addons?
  • tmilovantmilovan New
    edited November 2010
    I have started do getting them too after upgrade to 2.0.15. And yes, I'm using ProxyConnect along with many other addons.
  • This happens to me randomly sometimes too. It started after installing ProxyConnect for Wordpress. When logging out it asks if I "really want to sign out of" my Wordpress blog, then it redirects me to the wordpress login page.

    Then when I go back to Vanilla, I am signed in as a user with no name.
  • Hello,

    In my case I had to simply disable proxyconnect to resolve the issue.
  • Well what if ProxyConnect is the reason why you chose Vanilla as your forum software?

    It just happened to me again, this time without the redirect to the wordpress page.

  • Note: All of my cookie domains are the same and this happens on a seemingly random basis upon logging out
  • LincLinc Detroit Admin
  • I'm having the same problem with phantom users... including myself! How can I disable the proxyconnect plugin by remote so I (and my other users) can actually log in? I've tried renaming the plugins folder and etc, but that gives you bonk errors.
  • edited May 2011
    @Fastkarate You will need to edit /conf/config.php and delete everything that has "proxyconnect" in it. Also make sure you set $Configuration['Plugins']['ProxyConnect']['Enabled'] = TRUE; to FALSE. Save your config.php file and check your forum.

    After that you may need to manually delete all the ghost users via the admin control panel.

    I hope this helps you. :)

    Back up your original config.php file before editing it.
Sign In or Register to comment.