Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

syntax error

edited December 2010 in Vanilla 2.0 - 2.8
hello, am following the setup, loaded the file to my sever and tried to open it but it gave me a syntax error as follow ;

Parse error: syntax error, unexpected ',', expecting '(' in /homepages/45/d348388532/htdocs/vanilla/bootstrap.php on line 64

i open the bootstrap.php and line 64 looks like this;

Gdn::FactoryInstall(Gdn::AliasConfig, 'Gdn_Configuration', PATH_LIBRARY_CORE.DS.'class.configuration.php', Gdn::FactorySingleton);

am i missing out something? please help me out. thx in advance

Comments

  • do you have php5?

    /cd
  • i guess so! how can i find that out?
  • php version 4.4.9 am i in trouble?
  • One of the requirements of VanillaForums is PHP 5... There have been some threads in the previous days that certain people actually got Vanilla to work without certain requirements (PDO), but I am not sure about this. @Tim and @Todd might know / remember more.

    /cd
  • LincLinc Detroit Admin
    Having PHP 5.2 is critical. Vanilla 2 will not work without it.
  • i am now running php 5.2 but still not coming forward :(( same syntax error
  • ok ok ok i resolved the problem!!! for anyone who will be having the same problem;
    am no php guru but i figured
    PATH_LIBRARY_CORE.DS.'class.configuration.php'
    is different from
    PATH_LIBRARY_CORE . DS . 'class.configuration.php'
    i just had to space out the . DS .
    Wow after a day of headache i finally get to start enjoying vanilla!!!!
  • LincLinc Detroit Admin
    edited December 2010
    i figured
    PATH_LIBRARY_CORE.DS.'class.configuration.php'
    is different from
    PATH_LIBRARY_CORE . DS . 'class.configuration.php'
    No, it isn't. PHP doesn't care about white space. Glad your issue is resolved, though. The page was probably cached and it happened to clear when you edited that. Switch it back and I bet it keeps working. ;)
  • TimTim Operations Vanilla Staff
    ^^ What Lincoln said.

    Possibly you had APC and the opcodes were cached wrong.

    Vanilla Forums COO [GitHub, Twitter, About.me]

Sign In or Register to comment.