Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Dutch Locale won't work unless I set the $'Locale' parameter to 'en-CA'

This discussion is related to the Baseline Locale addon.
renerene New
edited January 2011 in Vanilla 2.0 - 2.8
I've made a Dutch locale based on the Baseline Locale addon. Thus far I've translated the captured.php file and I have the definitions.php file set-up. The Locale shows up in my dashboard, but nothing changes when I enable my addon.

I'm following the steps in but noting happens. What am I doing wrong?


  • renerene New
    edited December 2010
    [comment removed]
  • renerene New
    edited December 2010
    Could it be possible that I messed up some internal variable? I've edited files and folder names while my locale was enabled.
  • renerene New
    edited December 2010
    After some forum digging I checked the config.php file.

    Found an artifact rule $Configuration['EnabledLocales']['Dutch'] = 'nl-NL'; whilst this was not enabled in my dashboard. Removed it, enabled my Dutch locale from dashboard, and still no change. Locale is not working with the right definitions file.
  • I narrowed down what's causing the problem. At the moment I have the definitions.php file set-up for 90%. Changed the folder name to Dutch and set this variable. $LocaleInfo['Dutch'] and all the others.

    If I don't change $'Locale' => 'en-CA', to $'Locale' => 'nl', my locale works fine. If I do, a fallback to the english vanilla locale takes place.

    Before I upload my locale I want to be sure it will work as it should. Can anyone point me in a direction?
  • ToddTodd Chief Product Officer Vanilla Staff
    Have a look at the section under enabling your locale here:
  • renerene New
    edited December 2010
    I found this documentation earlier, but dismissed it as old information since my vanilla install has no "code" folder. Initially I thought this folder was replaced by the "conf" folder, but then I could not find the $Configuration['Garden']['Locale'] = 'en-CA'; line in the config.php file.

    I just added this line (with my own locale code) to the config file and it seemed to work.

    Why do I need to do this manually? It could be done after a user hits the "enable" button in the dashboard I guess? If another vanilla2 user wants to use my locale, will he also have to edit his config.php file?

    Anyway, thanks for pointing me in the right direction :)
  • LincLinc Detroit Admin
    @rene The /code/ folder was a typo which I've now fixed. Thanks for reporting it.
Sign In or Register to comment.