Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Migration from localhost to Webserver -> Bonk!

edited January 2011 in Vanilla 2.0 - 2.8

I finished my testing phase and decided to copy my whole forum on a webserver. I dumped the database, imported it onto the webserver, edited $Configuration['Database']['...'] to the new data and uploaded all files.

When I call it now it Bonk!s me shamelessly and considers itself as funky. :D

Is there anywhing else what I need to adapt to the new server's preferences?

Kind regards.


  • Go to the cache folder and then delete the files there.
  • Thank you for the quick reply, ChuckD!

    I just tried that, but it didn't succeed. What can I try next?
  • What about CHMOD? Do I need to give a special permission to seperate files?
  • Hi there,

    I have the same issue.
    I can't even activate the Debug mode by changing the line $Configuration['Garden']['Debug'] = true;

    I tried to change CHMOD in cache folder and still the same issue.
    I think there isn't no other folder to change than cache one, isn't it ?
  • XyoXyo
    edited January 2011
    I've tred CHMOD by changing to 777.
    Doesn't work at all.
  • oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    edited January 2011
    @bitch In your config.php, have you also updated all other site related information? Such as Domain & WebRoot, etc.?

    Have you enabled the Debug mode to receive a more detailed error description, rather than the bonk screen? To do so, copy the following line to your config.php:
    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';
    For any further help, it's essential to have an error description or something similiar.
  • XyoXyo
    edited January 2011
    Ok i've just figured out where the matter is for me.
    All name when you installed Vanilla start with prefix "GDN_" by default.
    Also, the tables name are all beginning by a caps.
    Result, for me, the name of the table wasn't recognized as if it exists .....

    My dump was done by mysqldump command, don't understand how this could arrive. Grumpf, so much wasted time just for this.

    @bitch, check if you have the same issue in your db.
    You can also add $Configuration['Database']['Prefix'] = 'gdn_'; line for example.
  • @Xyo: I also tried to get rid of it by setting CHMOD 777 to all files, but that didn't cause any difference.

    In the meantime I set up the forum completely new and set all preferences by hand again. Thanks for the advice with the database-prefix.

    In my case a new installation on the webserver worked. In PhpMyAdmin you can see that the prefix is uppercased online. On my localhost it's really lowercased. That's a reasonable error which could cause this. (: I didn't even think about this, nor would I have known to fix it by setting the right prefix in the config.php. Thank you very much, in case of needing to restore it out of any reason, I'll try to dump it and to fix it using your solution!

    @oliverraduner: Sorry for not giving an error message, next time I'll to so!

    Thank you all very much again.

    Kind regards.
  • XyoXyo
    edited January 2011
    Yep, I had the same issue in my case (database prefix).
    Just be sure you let 755 permissions for all files to avoid security issues.
  • LincLinc Detroit Admin
    edited January 2011
    @Xyo Apache does need write permission to the /conf/config.php file and /uploads & /cache directories. Unless the owner is Apache (usually it's not) or you have shell access, you'd probably need to set those to 777. I get around it by adding Apache to the group that owns the Vanilla files and using 775 instead since I have root on my servers.
  • In case your files owner is also the php executer, this is not a matter at all.
  • Hello,
    I also had this problem, Bonk things. Im migrating from another host, and my table prefix with GDN_ But I always see this bonk. Im still new on vanilla, every help would be appreciated.

  • AoleeAolee Hobbyist & Coder ✭✭

    delete all the *.ini files in the cache folder, check your conf/config.php

    $Configuration['Database']['Name'] = 'DBNAME';
    $Configuration['Database']['Host'] = 'localhost';
    $Configuration['Database']['User'] = 'root';
    $Configuration['Database']['Password'] = '';

    Check out my other Plugins here

Sign In or Register to comment.