Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[SOLVED] Vanilla rewrite urls "forum settings" doesn't work

edited February 2011 in Vanilla 2.0 - 2.8
Hi Everyone,

I've installed the forum, amended the config and uploaded .htaccess. Everything's working great but...

All the links within the Dashboard area under the Forum Settings heading (categories, spam, advanced) don't. They instead go to etc although my forum is installed within the root of the domain.

When manually removing the 'vanilla' directory from the link in still doesn't work. I get a "Page not found - The page you were looking for could not be found." Error.

Any ideas how to get these last three links working?



  • Options
    I don't know the actual answer, but look in the cache directory. Maybe there's still something left that contains the vanilla directory name. Maybe some .ini files.

    If you have the possibility to look in all your files (with a text editor), look for the vanilla directories, maybe some are hardcoded.

    There was an error rendering this rich post.

  • Options
    LincLinc Detroit Admin
    edited January 2011
    Try deleting the .ini files in the /cache folder.

    There shouldn't be any hard-coded directories.
  • Options
    How bizarre, I've removed the 3 .ini files from the /cache directory and it's still showing. I've now got 2 separate installations both doing exactly the same thing. Both are hosted with MT and are clean installations.

    Have you got any other ideas?
  • Options
    Hi Everyone,

    I've installed the forum, amended the config
    Can you please be more specific?

  • Options
    I literally just changed this row:

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    So that it reads TRUE.
  • Options
    Okay Okay - It would probably help if I didn't just hover over the links, but actually pressed them too. Although it says /vanilla, they now actually work!

    Must have been the .ini files. Thanks Lincoln & UnderDog!
  • Options
    edited February 2011
    Yes that's what it does. I thought you meant you were recieving an error. Anyway I think your questions have been answered so locking this topic :)

This discussion has been closed.