Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Vanilla Core 2.0.17.x] Error - 'CategoryModel' not found



  • Hey, I had that problem.

    It was because I forgot to clear out the database after my existing install of Vanilla.

    Dropped all the old Vanilla tables and now it works fine!
  • @deathdroid - I've done 2 separate installs (core- and commenting out those lines worked like a charm. Been a month since this thread was commented on and wondered if it was being addressed elsewhere. Hate being in the dark about changing the core.
  • I seem to have exactly the opposite problem which I am trying to descibe elsewhere on these pages and which is a currently active discussion. At present line 60, as copied above, is apparently the cause of a fatal error.
  • I had the same exact problem. Basically, when you do a new reinstall, you have to remember to clear out your database of everything. Obviously, this is not good advice if you already have an existing database with legitimate data.
  • try opening up conf/config.php
    and make sure this line exist under EnabledApplications

    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
  • LincLinc Detroit Admin
  • I found a work-around:

    1. Download a copy of your database.
    2. Delete your database.
    3. Create a database with the same name.
    4. Install Vanilla
    5. Once it's working, upload your backup.

    It worked for me at least.
  • Managed to get a work around for myself too. I think this is linked to the Zend Server CE issue.

    1) Comment out the CategoryExists check in structure.php as per deathdroid above.
    2) Before that comment, put in a var_dump($CategoryExists);exit; call.
    3) Run the installer. It should say Boolean(False) and an otherwise white screen.
    4) Do it again. It should now say Boolean(True)
    5) Uncomment the section in (1), but after the 'if' line add in:
    You'll have to change 'vanilla' to be the dir in the doc root you installed Vanilla into.
    6) Run installer again. This will activate the Conversations installed application, but not Vanilla itself.
    7) In the dashboard, activate Vanilla.

    I've done this twice now to reproduce it. So it's working for me. Messy, but I get a forum out of it.
  • deathdroid said:
    I have a temporary work around, I wouldnt reccomend anyone using this. But if you comment out

    if ($CategoryExists) {
    $CategoryModel = new CategoryModel();

    It will allow you to install it, and it should as far as i know run fine, but i havent tested this on a live forum, just on a localhost.

    It works on a live forum. thanks for the workaround deathroid.

  • edited December 2011

    My work-around was to make sure structure.php finds the category model class by including it at the top of structure.php:


    (Adjust the /path/to/vanilla part to point to the directory where you installed Vanilla.)

Sign In or Register to comment.