Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] Problem with shortening URLs

edited February 2011 in Vanilla 2.0 - 2.8
Okay, going over the how to post a question post:

I meet all the requirements on the server, my permissions are fine, my platform is ubuntu 10.04, it's a new clean install.

The vanilla files (there is no vanilla folder) is located at, now originally even didn't work. I instead had to go to, now I've changed certain apache settings, so that I can now access the forums by going to

Now whenever I clicked any of the links it would take me to, I wanted to get rid of the index.php?p= so I went to config.php and changed:

$Configuration['Garden']['RewriteUrls'] = TRUE;

to equal to TRUE.

Now I can still access my forums at, when I click any of the links it takes me to say (which is what I wanted) but the pages display an error and don't work.

So, err, what's wrong?


  • but the pages display an error and don't work.
    Which error do the pages display? A 404 error or a BONK error? Or maybe another error? (like apache spits out).

    There was an error rendering this rich post.

  • edited February 2011
    E.g. typing in "" gives:

    "Not Found
    The requested URL /forum/discussions was not found on this server."

    Whereas typing in "" shows a valid page.
  • Ok, that's a 404 error. Something is wrong when enabling the RewriteUrls config setting. Do you know if your server has mod_rewrite enabled?

    There was an error rendering this rich post.

  • Well my .htaccess, has 'RewriteEngine On'.

    This is how it looks like:

    # Original
    # If you modify this file then change the above line to: # Modified

    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    RewriteBase /forum
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

    Also the full server filepath for the forum is home//public_html/

    Is it possible that on the line where it says 'RewriteBase /forum' i'm doing something wrong?

    Also do I have to do anything in httpd.conf in my apache folder? Though I think any .htaccess file overrides any previous httpd settings?

  • i have this same issue.
    Hosting with godaddy
    rewrite urls has never worked for me
  • Odd, although I do not have GoDaddy hosting, my domain registrar is GoDaddy.
  • Still experiencing the problem. I think no reply in the past two days warrants a bump?

  • I have the same problem. I set the config to TRUE and my .htaccess says RewriteEngine On. This is on a local development system.
  • Ok obviously a lot of people are having the same problem. Help anyone?
  • Again no reply for the past 4 days now..... ...

  • LincLinc Detroit Admin
    I bet you have AllowOverride set to 'none' for that folder. If that's the case, it needs to be set to 'all' for that directory in your Apache config.
  • thanks for this thread
  • Yep AllowOverride set to 'all' works! Thank you Lincoln!
Sign In or Register to comment.